Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So i just got in a shipment of Dell D830s, and im trying to do a PXE boot to our WDS servers....but when I get past the boot option screen to the pre PXE screen that asks for "Press F-12 for network boot"...my F keys appear to be disabled. This is strange because I use f-12 to get to the boot options menu. I've messed with every Bios option I can think to, and Google has only turned up changing my WDS config, which i would rather avoid as it works with every other model.

share|improve this question

Is there an f-lock key? I've come across this on media centre type keyboards but not on anything else.

share|improve this answer
    
This particular model is a laptop, and I dont see any F key toggles. – Matt Aug 18 '11 at 17:17
    
I would have suggested maybe the fn key was stuck but from context I'm guessing you've tried more than one of the laptops – Col Aug 18 '11 at 17:30
    
Yessir. They have been disk killed and shipped from a sister office as well. I've also confirmed that the WDS is active and functioning. Usually there is a Bios setting for F key behavior on boot...but in this case all I can find is Fn options. I also tried spamming different variations of the Fn key, ctrl, alt and with num lock on and off...just on the off chance lol. – Matt Aug 18 '11 at 17:35
    
Have you made sure your network card is set to on with PXE in the bios some Dell documentation seems to suggest the default is on without PXE – Col Aug 18 '11 at 17:40
    
PXE picks up the DHCP and registers the IP and is ready to boot to the PE environment...but I can't confirm the network boot because f-12 wont register as a keystroke. – Matt Aug 18 '11 at 17:42

Recent Dell computers have a BIOS setting that swaps the default position of the Fn key. Try using Fn+F12 or going to the BIOS and toggling that setting.

I know you said it can't be this because you can use the key to get boot options, but I'm not convinced: the boot options may be looking for either F12 or the Fn version.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .