Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've tried using this How-To Geek guide, but it doesn't work. Running the script from the terminal works (although I had to change its permissions first), but clicking on a mailto: link does nothing.

Note: I am using the Chromium Daily Builds for my browser. I would mailto: links in all applications to point to gmail, not just the ones that I click on in my browser.

share|improve this question
add comment

6 Answers

up vote 11 down vote accepted

As of Ubuntu 10.04, you can simply install the desktop-webmail package. The first time you click a mailto: link, it will ask you to pick your webmail provider. After that, all mailto: links will open in the webmail provider of your choice.

share|improve this answer
1  
this no longer works in 11.04 –  wim Aug 30 '11 at 5:44
    
@wim: I'm not currently running 11.04. Can you explain why it doesn't work? Does desktop-webmail not exist? Or is there a different problem? –  Matthew Aug 30 '11 at 14:57
    
There is not an option to select Desktop Webmail as the Mail Reader in System -> Preferences -> Preferred Applications -> Internet -> Mail Reader, you have to do some mucking around to get it to appear in that combo box. –  wim Aug 30 '11 at 23:43
    
@wim: Because we want this page to be useful to anyone who stumbles across it, could you post the details of the required mucking around? –  Matthew Aug 31 '11 at 16:06
1  
It involves making some changes in file /usr/share/applications/desktop-webmail.desktop, and too much to post in a comment. In 11.04 it's easier just to use an alternate method: 1) install gnome-gmail 2) edit ~/.local/share/applications/mimeapps.list adding line: x-scheme-handler/mailto=gnome-gmail.desktop –  wim Sep 1 '11 at 0:14
show 1 more comment

In my gnome-default-applications-properties, I set the following custom mail reader:

gnome-open https://mail.google.com/mail/?extsrc=mailto&url=%s

(In gnome-default-applications-properties, also make sure that the default browser is set to Chrome/Chromium.)

Note that this only affects external applications (e.g. gnome-terminal) that invoke a mail agent. mailto: links within Chromium itself work as of r25100. (Chromium Bug 20696)

share|improve this answer
    
I've picked this as the accepted answer, but you might want to edit it to include Days_of_Ruin's tip--none of this will work in Chromium until mailto: handling is implemented. –  Matthew Sep 2 '09 at 13:20
1  
Good idea, done. I found out that mailto: support in Chromium itself was committed yesterday (r25100), so a daily build should pick it up soon. The implementation calls out to xdg-open so I believe that once you have configured gnome-default-applications-properties to use Gmail as above, the setting should carry over to Chromium. See code.google.com/p/chromium/issues/detail?id=20696 for the details. –  Phil Sep 2 '09 at 21:26
    
I just updated Chromium from the daily PPA and mailto: now works. –  Matthew Sep 2 '09 at 21:29
1  
For some reason using your command in "Preferred Applications" opens a "compose" tab for gmail, but with a blank "To: " field. Any idea why? –  Matthew Nov 12 '09 at 22:03
    
I had success with one Ubuntu installation but not another. I'm afraid it's a regression between releases, but haven't had time to track it down... –  Phil Nov 23 '09 at 3:15
add comment

I use the daily builds too and when I click on a mailto link it doesn't do anything. I don't think that they have implemented mailto handling yet.

share|improve this answer
    
I think you are right--using Phil's tip, mailto: links everywhere but Chromium now work. –  Matthew Sep 2 '09 at 1:19
add comment

Since you are using Chrome, you can install an extension which redirects all mailto links to Gmail.

share|improve this answer
add comment

are you using firefox? if so it doesn't really matter if you are using different OS, try this redirect open mail-to link to Gmail in Firefox

Go to Toos > Options > Applications (Search for ) mailto

Under the Action Drop down menu Click Use Gmail or other applications, because this by default it will launch Microsoft Office Outlook. By doing this now you can send email and click the link right inside your browser without worry the Outlook bother you ever again.

share|improve this answer
    
Thanks for your answer, but I am using Chromium. I've edited my question to show that. –  Matthew Aug 30 '09 at 19:18
add comment

On debian wheezy, all you need is:

$ sudo apt-get install gnome-gmail

I could not get the magic javascript code to work (from: http://updates.html5rocks.com/2012/02/Getting-Gmail-to-handle-all-mailto-links-with-registerProtocolHandler)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.