Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a pictures folder on my Western Digital My Book World Edition NAS. Using Windows 7 Home Premium SP1, when I right click on a folder inside, I get the loading icon that lasts a long time (approximately 15 seconds or more).

It seems the larger the folder, the longer it takes. However, just right clicking in the folder, it takes about 5 seconds for the right click menu to come up. Also thumbnails inside take a long time to load.

This happens on my computer as well as another one on our home network. Restarting the router and NAS had no effect.

If I do the same things on my local drive, there is no delay.

What can I try to improve this? Let me know if you require additional information.

share|improve this question

5 Answers 5

You have a context menu shell extension that's causing this. Check the 3rd party software you have and start disabling them one by one until you find the culprit.

Common culprits are virus scanners and compression utilities (for example, checking .exe files for SFX stubs).

share|improve this answer

usually it's the OS + whatever context handlers you have for the file types trying to read the file metadata, e.g., reading the picture to create the thumbnail, extracting image size info, etc.

share|improve this answer

You should check for any registry key orphans.

In my case it was my archiving program, WinRar. I uninstalled it a while back and had switched over to 7zip. Once I deleted the WinRar key from the registry there was no more delay on my right-clicking.

share|improve this answer

Use this utility - http://www.nirsoft.net/utils/shell_menu_view.html

It decreased my Exlorer menu from +15 secs to under 1! Just be careful which context entries you disable...

share|improve this answer
1  
Please add some more information! Like: what does the tool do, what did you configure, how did you configure it... –  Simon Apr 24 '13 at 10:58

Your network speed may be affecting data transfer rates between the NAS and your computers. Depending on how fast the NAS is able to deliver data, the network speed could be a significant factor.

Ideally you should be using gigabit Ethernet to ensure fastest possible data transfers. This requires a switch or router with gigabit-capable ports, gigabit ports in your NAS and your computers, and CAT5E or CAT6 cables. If you're using 100 Mbps or WiFi, then you'll get significantly slower data transfer rates, which could be causing the performance issues you're seeing.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.