Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Mac OS X 10.7 Lion and am trying to disable Spotlight indexing on my Time Machine hard drive, as the mds and mdworker processes are running wildly through all day at 15-60% of CPU...

What bugs me is not that my MacBook is running slowly but that this CPU consumption kills some cycles of my battery through time just for a wasting-never-used search in my Time Machine backup...

I've tried to add the Backups.backupdb folder from the Time Machine HD to the Privacy list, but I get this message:

“Backups.backupdb” is a Time Machine backup folder. You cannot add it to the privacy list.

I then tried to completely stop Spotlight using sudo mdutil -a -i off; this is the output:

/:
    Indexing disabled.
/.MobileBackups:
    Indexing enabled. 
/Volumes/Files:
    Indexing and searching disabled.
/Volumes/Komodo-Edit-6:
    Indexing disabled.
/Volumes/MobileBackups:
    Index is read-only.
/Volumes/MobileBackups/Backups.backupdb:
    Index is read-only.
/Volumes/TimeMachine:
    Indexing and searching disabled.
/Volumes/TimeMachine/Backups.backupdb:
    Indexing enabled.

How can I disable this annoying Spotlight behavior? I don't use it very much and it would be painless to disable it for good, or at least stop indexing my Time Machine backup...

share|improve this question
    
Try this solution: superuser.com/questions/318787/… I hope it works for you. –  Ernani Joppert Nov 15 '11 at 21:41

2 Answers 2

up vote 2 down vote accepted

Most likely it is not possible

From Spotless's (An OSX app which helps disable Spotlight indexing) change log:

We also added support of Time Machine backup volumes. 
Since these volumes cannot have their indexing disabled permanently, 
Spotless no longer attempts to modify them.

So it looks like even programmatically you can not disable Spotlight from indexing Time Machine.

share|improve this answer
    
If I add the whole disk to the Privacy list it still says that files from the disk will not be indexed but the TimeMachine backup will... Also, Spotless won't run in Mac OS Lion –  piva Aug 18 '11 at 23:07
    
There might not be a way to prevent it from indexing TM. Seems like what I said above worked for a bit but then maybe an update started preventing people from not indexing TM. What does the message says exactly? Check out this discussion: tech.kateva.org/2011/06/… –  Steve Moser Aug 18 '11 at 23:14
    
Ok... So I'll need to let my TimeMachine disk ejected, lol, thanks for the answer :D –  piva Aug 19 '11 at 4:44

This answer is obviously late, but I came across it and thought an answer might be useful to anyone who still has a question about this issue. Using Yosemite (and Mavericks and Mountain Lion if you are still on those versions of OS X; I'm not sure about Lion, but if this option exists on Lion, then I assume it would work), the way to stop Spotlight from indexing (and conducting searches in) your Time Machine backups on an external hard drive is: 1) open Spotlight in System Preferences; 2) click on Spotlight's Privacy option; 3) then just drag your external hard drive's icon (assuming it's visible on your Desktop) into the Privacy list. That will keep Spotlight from indexing and searching all of your Time Machine backups.

You can do the same thing with other folders on your internal hard drive that you don't want Spotlight to search or index (e.g., caches, logs, and other constantly changing folders that just use up CPU and give you search results that are of no value). Just locate the folders on your internal hard drive and drag them into Spotlight's privacy list. They, of course, physically remain in place on your hard drive.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.