Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed xampp and made sure config file listens to port 80. I forwarded the http port from the router to the correct computer ip. Now I am trying to access the index.html like this from another house http://myip:80 But it is not working. What could it be wrong?

share|improve this question
    
Does it work via localhost? –  boot13 Aug 19 '11 at 22:27
add comment

migrated from stackoverflow.com Aug 18 '11 at 22:26

This question came from our site for professional and enthusiast programmers.

2 Answers

If you are using Windows-System, try the following steps to find the bug:

  • First of all, try to reach the host by using the ping-command.
  • If this works, make sure, that the hosts-firewall ist not blocking incoming request to port 80.
  • There are the following, necessary settings in your httpd.conf-file:
    • Listen 80
    • ServerName YourServer:80 Try to use ServerName the same name as your Windows-Computername.
  • It might be useful to know, if you run SKYPE, there's an option that allows Skype to use port 80 for communication. This might block the apache-service to run properly and maybe prevents the page from beeing accessed.

I hope, this helps!

share|improve this answer
add comment

You must to have at least server with used ServerName in Apache config Can't tell more while I don't know - Do you use virtual hosts - Which module, if use

In short - show you httpd.conf after comment "main" server configuration

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.