Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My workplace uses a Cisco VPN. When I'm at home, connected wirelessly through my Linksys router, I'm having trouble loading HTTPS sites. (I'm using Ubuntu, which doesn't cache DNS entries) Here's a typical scenario:

  1. Open Firefox/chrome
  2. Visit, logged in
  3. Connect to the VPN
  4. Click any link from Github home page (someone's repo for example)
  5. Website just sits there spinning (Firefox's status bar displays "waiting for ...")
  6. Clear cache - makes no difference
  7. Open github in new tab and click the same link again - doesn't work either
  8. Restart Firefox
  9. Open github and click the link again - now it works.

I've also tried:

  • Explicitly using OPENDNS servers for both my VPN connection and wireless connection
  • Disabling Firefox TLS

Would really appreciate any help debugging this at all!

share|improve this question
Your VPN server is likely to be meddling with the HTTPS layer. – grawity Aug 19 '11 at 10:10
up vote 0 down vote accepted

Talked to my network admin. He said that this is expected because our VPN uses full tunneling. Because the underlying IP address used for the SSL changes, there is no way to circumvent this by clearing any sort of cache. You have to restart your browser or maybe logout and log back in.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .