Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My desktop's NIC doesn't want to connect to my switch, even though the laptop will do so (using the same jack and ethernet cable.)

Set-Up: I'm in the process of running CAT6a cable to all the major rooms in my house. Although none of my endpoints are above a gigabit in speed, I'm trying to future-proof the infrastructure.

Problem (High-level): Using the same jack and ethernet cable, my laptop (a dell XPS M1530) connects successfully to the switch, but my desktop (using a NIC built into MSI P67A-GD65 B3 motherboard) fails to do so. The switch is a D-Link DGS-1024D. Both machines are running Windows 7 Ultimate x64.

Problem (additional-details): Looking at the network icon in the tray on the laptop shows the ethernet adapter as being connected to a "Network" and having an internet connection. Whereas the desktop shows its ethernet adapter as being connected to an "Unidentified Network" and having no internet connection.

Furthermore, by looking at the "Local area connection status" on the desktop, I noticed that it is never receiving any packets from the switch. It does, however, correctly identify when the ethernet cable is inserted and removed.

Things I've Tried: These were the big things I've tried so far, that didn't help.

  • Made sure that I'm running the latest drivers on my desktop. (Realtek PCI-E Ethernet Drivers v7.043).
  • Reinstalled the driver.
  • Rebooted
  • Flushed DNS
  • Renewed the IP.
  • A browser search brought me to this page which mentioned that the Boujour DNS Responder Service may cause problems. I am not running that service.
  • Tried forcing various speeds and duplexes in the NIC'd advanced configuration page.
  • Forced desktop to use laptop's IP settings (see below).

Helpful Details (Hopefully): When the laptop (successfully) connects to the switch running ipconfig shows the following information:

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix  . : hsd1.wa.comcast.net.
Description . . . . . . . . . . . : Marvell Yukon 88E8040 PCI-E Fast Ethernet Controller
Physical Address. . . . . . . . . : 00-21-9B-D4-46-30
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::91c:9d7d:997a:bf54%10(Preferred)
IPv4 Address. . . . . . . . . . . : 50.132.27.162(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.254.0
Lease Obtained. . . . . . . . . . : Friday, August 19, 2011 12:43:04 AM
Lease Expires . . . . . . . . . . : Monday, August 22, 2011 9:40:24 AM
Default Gateway . . . . . . . . . : 50.132.26.1
DHCP Server . . . . . . . . . . . : 68.87.69.10
DHCPv6 IAID . . . . . . . . . . . : 234889627
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-14-BA-B5-F3-00-21-9B-D4-46-30

DNS Servers . . . . . . . . . . . : 68.87.69.150
                                    68.87.85.102
NetBIOS over Tcpip. . . . . . . . : Enabled

When the desktop fails to connect an ipconfig shows the following information:

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix  . :
Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
Physical Address. . . . . . . . . : 6C-62-6D-3B-DF-92
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::b8a9:2901:672e:7916%14(Preferred)
Autoconfiguration IPv4 Address. . : 169.254.121.22(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :
DHCPv6 IAID . . . . . . . . . . . : 174875245
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-15-53-8A-F1-6C-62-6D-3B-DF-92

DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                    fec0:0:0:ffff::2%1
                                    fec0:0:0:ffff::3%1
NetBIOS over Tcpip. . . . . . . . : Enabled

Although both the laptop and desktop were forced to automatically get their IP address, I've tried to force the desktop to use the laptop's IP settings, but that didn't solve the problem. Instead it showed that the IP was already in use (weird, because the laptop was no longer connected to the switch at all). Forcing the desktop to use 50.132.27.163 as its IP did not show the IP collision error, but also did not enable internet access on the desktop.

Finally, running an arp -a on the desktop showed the following, but I didn't know how to interpret that information.

Interface: 169.254.121.22 --- 0xe
  Internet Address      Physical Address      Type
  169.254.255.255       ff-ff-ff-ff-ff-ff     static
  224.0.0.22            01-00-5e-00-00-16     static
  224.0.0.252           01-00-5e-00-00-fc     static
  255.255.255.255       ff-ff-ff-ff-ff-ff     static

I'm running out of ideas, any additional help would be appreciated.

share|improve this question
add comment

2 Answers

up vote 4 down vote accepted

Not really sure why the other answer got downvoted. I would of said the same based on the information provided.... but a little extra -

You are using public IPs on a private network. If not intentional, this is a weird set up and I concur with m0skit0 that it looks like you have DHCP problems or other infrastructure errors.

Some routers/switches (managed) and other devices remember IP addresses that were in use (have a longer time out) which can cause errors when quickly reusing the same IP address with different NIC/MACs.

Unless you are attempting to give a public IP to every machine, and/or if you do not have a DHCP server, if all these machines are on the same network/subnet, I would highly recommend just using the 192.0.0.x range with subnet 255.255.255.0, and choose a unique number for each machine.

If this isn't right/helpful, please can you say a little more about your network - your setup isn't straight forward and it would help to learn a little more - where the router is, are you attempting to use public ips etc.

share|improve this answer
    
Well I have no idea why my answer got downvoted as well, specially since I got no answer to the following procedures stated on the comment. –  m0skit0 Aug 19 '11 at 9:35
    
@m0skit0 0 Just given you +1! As I said, it is what I would of said. –  William Hilsum Aug 19 '11 at 9:36
    
Thanks William. Let's see if we can figure out what the problem actually is :) –  m0skit0 Aug 19 '11 at 9:38
1  
You're a genius. I had the set-up going: Modem --> Switch --> router instead of modem --> router --> switch. This caused the switch to share the modem's external IP address on the internal network. Now I'm curious how it worked on the laptop at all. :) –  Rob Rolnick Aug 19 '11 at 9:39
    
@Rob Rolnick - The modem (or your ISP) may have DHCP, but, only one single IP address available to you, and maybe with a timeout or similar so it all depends on the order that you turn components on. It is really hard to try to second guess someone else's infrastructure! –  William Hilsum Aug 19 '11 at 10:05
add comment

I think your problems comes from the fact that the laptop machine is using a manually configured TCP/IP settings while your desktop machines is trying to use a not existent (or not answering) DHCP server. See here:

Laptop:

IPv4 Address. . . . . . . . . . . : 50.132.27.162(Preferred)

Desktop:

Autoconfiguration IPv4 Address. . : 169.254.121.22(Preferred)

Usually when no DHCP answer is got, Windows machines are left with 169.254.X.X IP address. Also no DNS servers have been set. And your desktop's IP address obviously has no relation whatsoever with the address and netmask that is shown on laptop settings. Thus I think your problem definitely is TCP/IP settings configuration.

Manually configure your desktop TCP/IP settings like the ones shown on laptop's configuration and try again (only connect the desktop machine, or you'll have IP conflicts).

share|improve this answer
    
I tried that, it didn't work. To quote the original post: "Although both the laptop and desktop were forced to automatically get their IP address, I've tried to force the desktop to use the laptop's IP settings, but that didn't solve the problem. Instead it showed that the IP was already in use (weird, because the laptop was no longer connected to the switch at all). Forcing the desktop to use 50.132.27.163 as its IP did not show the IP collision error, but also did not enable internet access on the desktop." –  Rob Rolnick Aug 19 '11 at 9:04
1  
I think it did not work because ARP caché (caché that relates IP to Ethernet addresses) is not flushed. That's why you get the "IP already in use" error. Anyway, if you say 50.132.27.163 was no use as well, then that's not the problem. Did you correctly set the netmask (255.255.254.0) and DNS servers as well? Can you try pinging another machine on the network? –  m0skit0 Aug 19 '11 at 9:09
    
Nope, I correctly netmasked. I mirrored all the settings. See my response above to William Hilsum, the problem was in the order of the components, not the configuration of the hardware (like I thought.) No idea how the laptop worked at all. (And yes, I made sure to disable the wireless NIC when testing the laptop.) –  Rob Rolnick Aug 19 '11 at 9:41
1  
Well, glad you got it fixed :) –  m0skit0 Aug 19 '11 at 9:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.