Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm working on some code from my computer at home and would like to do CVS updates to a remote server. When I'm at work I don't need to type in a password, but at home each time I need to type in my password each time I do a CVS update.

I've followed the instructions here on how to set up a passwordless public/private ssh key pair: http://www.ece.uci.edu/~chou/ssh-key.html

However, after that I still need to type in my ssh password each time I do CVS update (or anything CVS related) from my local computer.

What am I missing?

share|improve this question
    
Ok, now it says "ssh_exchange_identification: Connection closed by remote host" whenever I try to do a CVS from my local machine. I've had this problem before when messing around with ssh keys and usually after 24 hours I can access the server again. I'll try again tomorrow but I'll still have that problem with having to type in my password each time –  Eddy Aug 19 '11 at 21:19
    
see below - how do the permissions of ~/.ssh/authorized_keys look like? Don't give anyone except the user write permission, or the SSH daemon will refuse to accept that (security risk - anyone could paste in his key if he can write to the file) –  Florenz Kley Aug 29 '11 at 15:46

1 Answer 1

What you did was setting up SSH authentication, and that works for everything using SSH as transport. As long as you are using the :ssh: method it should work for CVS to.

Have look at the CVS/Root file inside a checked out directory to see what access method you are using, it should say

:ext:jrandom@cvs.foobar.com:

for transport over SSH.

share|improve this answer
    
Yep, mine says :ext:user@remotehost.com:/home/cvs –  Eddy Aug 19 '11 at 21:16
    
funny. What does interactively connecting with SSH say? Does that work without a pasword? If not, do the permissions of the ~/.ssh/authorized_keys only allow "w" for the user? –  Florenz Kley Aug 29 '11 at 15:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.