Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have many MP3's with embedded cover art in them (bought them like that) When Windows Media Player plays one of these, sometimes it displays the correct cover but most of the time, it displays the cover from a song that was previously played, sometimes several days before!

I have had this problem for a very long time! And it survived and recent reinstall of Windows 7 (hard drive crash).

My problem is similar to this one but no solution has been posted.

If I try to reproduce the problem at this moment, what happens is that when I double-click on a MP3 in Windows Explorer (Windows 7, WMP12 not already running), the cover that will be displayed is from a MP3 I played earlier in the week, which we'll call (A). The cover display in the status bar of Windows Explorer is correct though. When I change MP3s, (Windows Media Player running this time), sometimes the cover stays stuck still on the cover of (A), sometimes it displays the good one. If I quit at this time and restart Windows Media Player with the same MP3, the cover of (A) is back again...

I do remember having another behaviour closer to the one described in the link, that is, Windows Media Player was lagging always one cover art, displaying the art of the previous song, but maybe that was with WMP11, I can't remember

Did anyone experience this problem and found a solution?

share|improve this question
up vote 1 down vote accepted

Your problem is caused by the file AlbumArtSmall.jpg in the mp3's directory. You cannot delete (or see) this file using the any Windows tools, but you can see it and delete it using the Cygwin command-line tools (ls and rm) or possibly some other third party tools. This won't permanently fix it however. As far as I know, there is no way to stop WMP from doing this.

The only solution I can think of is placing different albums in different directories. This way the AlbumArtSmall.jpg file will be unique for each album.

share|improve this answer
Totally! I found this by myself and was coming back to Superuser to answer my question! Thanks! See below to read my full story – Nawak Aug 21 '11 at 14:33
This answer is not entirely correct. You can view and delete the file if you activate View > Options > Change folder and search options > View > Hide protected operating system files. – BananaBoss May 5 '15 at 19:32

TL;DR: see 2 possible solutions at the bottom

As noted by Nithin Philipps, the problem lies with the fact that all these MP3 were in the same folder and shared the same Folder.jpg and AlbumArtSmall.jpg. (I found this independently by using "Process Monitor" to find all the file access done by Windows Media Player and saw that it looked for a file named "Folder.jpg" and if it didn't find one (because I deleted it!) it created it (from the embedded MP3 cover) after 15s!)

I also found a page advising to delete these files, create new empty ones (0 bytes) and deny-write them by ACL. This way, Windows Media Player falls back to using the embedded art. ( )

I protected my "downloads" folder this way as MP3 bought on VirginMega end up there. MP3 bought on Amazon end in different folders ("Artist Name"/"Album name"), so I didn't need to do anything for them.

I also found that Windows Media Player doesn't create the folder.jpg if the MP3 are on a network share (I guess it's because it can't hide them with the system attribute?), so when I get around to sort my new MP3 on my NAS, the problem will go away anyway.

So there are indeed two solutions for this problem:

  1. "Protect" the folder containing the MP3 by creating empty Folder.jpg and AlbumArtSmall.jpg, and then denying write on them with ACL.

  2. Put your MP3 on a Network Share (maybe a FAT drive would also work?). Using a RAIDed NAS to protect them is a good idea anyway, hard-drive crashes aren't nice!

share|improve this answer
+1 For the network share tip. I share my mp3 folder as a read-only network share so WMP wont screw up all the cover art I painstakingly fixed. – Nithin Philips Aug 21 '11 at 22:13

The problem is in AlbumArtSmall.jpg located in your MP3 folder.

Contrary to other answers, you can delete this file without downloading an extra folder. Find Change folder and search options, and you must deselect Hide protected operating system files (Recommended), not the Show hidden files, folders and drives. This will cause several files to appear, even with all that has been shown by the latter, included is the file AlbumArtSmall.jpg. Delete that, there will also be Folder.jpg, delete that as well.

Afterwards, play your file and everything should be fine. It is recommended you re-select the Hide protected operating system files (Recommended) so as not to accidentally delete anything of importance.

share|improve this answer

If you enable "Show hidden files" and uncheck "Hide protected operating system files" in folder options and then manually delete any images but the "correct art", it should use the "correct art". Right click on an album or track in the Windows Media Player interface and "Open File Location". Then cut & paste the correct art and it should stick.

WMP12 seems rather cludgy. If you use any other third-party music apps like Zune, iTunes or even Windows Media Center it creates a hectic disorganized mess of album art because they all use different formats. I right click on the art and hide them once they are set up like I want them.


share|improve this answer

The problem is caused by Windows Media Player and not by Windows. I've just changed the settings on Windows Media Player. I prevent it from being my default player, from adding any file to this player's library or doing any other automatic action. (go through all the possibillies and check) and I got read of this annoying phenomena. Now each song or album has the picture I want it to have.

share|improve this answer
  1. Copy desired artwork to Clipboard.
  2. Open Library and right click the existingartwork / space.
  3. Select Paste Album Art.
share|improve this answer

The ID3v2.x specification allows an .mp3 file to contain numerous embedded images (Front cover, Back Cover, Band, Band Live, Band Logo, Leaflet Page, etc). Windows Media Player has a bug and does not correctly display the correct Front Cover image. Instead, I suspect it is simply retrieving the first embedded image it finds and displaying it, regardless of what kind of image it is. My .mp3 files have all sorts of images embedded in them, and Windows Media Player displays random images. This is just one of a whole slew of bugs in Windows Media Player regarding mp3 files. Sometimes I think Windows Media Player was written by a bunch of monkeys.

share|improve this answer

This is how I fixed my problem (CD art display was wrong)

Open up Windows Media Player On the left click Organize, Options

Select the Privacy tab Click on Clear Caches Clear History Click OK Close WMP and reopen to play the album. The correct album art appeared on the screen

share|improve this answer

There is a fix for this

  • exit Media player and go to %LOCALAPPDATA%\Microsoft\Media Player and delete the files and folders within
  • restart Media Player
  • the library will need to rebuild

Should the problem remain, go to %LOCALAPPDATA%\Microsoft\ and delete the folder Media Player, again the library will need to rebuild.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.