Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I don't know if it makes a difference, but I downloaded the SDK from the official oracle site and I picked the linux x86 compressed binaries (second item on the list). I'm on Windows 7 with an i7, but trying to install on an Ubuntu 11.04 VM I have running inside VirtualBox.

I tried following this tutorial, but it's not working.

java -version
bash: /usr/lib/jvm/jdk1.7.0/jre/bin/java: No such file or directory

Then I try

ls -al /usr/lib/jvm/jdk1.7.0/jre/bin/ja*
-rwxr-xr-x 1 foo foo  5650 2011-06-27 04:02 /usr/lib/jvm/jdk1.7.0/jre/bin/java
-rwxr-xr-x 1 foo foo 16074 2011-06-27 04:03 /usr/lib/jvm/jdk1.7.0/jre/bin/java_vm
-rwxr-xr-x 1 foo foo 76665 2011-06-27 04:03 /usr/lib/jvm/jdk1.7.0/jre/bin/javaws

Any ideas?

share|improve this question

closed as too localized by slhck, studiohack Jan 31 '12 at 21:50

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
The only difference I can spot between what you're seeing and the instructions is that the bin folder in the instructions is inside a jre folder, I'm not sure if that's relevant or not. –  Col Aug 20 '11 at 8:00
    
That is a good point; but after going back and fixing it I'm still having trouble getting it going. I've updated my answer with relevant details. –  Dave Aug 20 '11 at 14:25
    
Voting to close as too localized now, since it seems like the problem was somewhere else. –  slhck Jan 31 '12 at 21:49

1 Answer 1

up vote 1 down vote accepted

I was, in fact, using the wrong jdk. I was using i586 when I should have been using x64 binaries.

share|improve this answer
    
Should I delete this question, or is this information useful enough that I should leave it? –  Dave Aug 20 '11 at 17:06
    
This doesn't have anything to do with Vbox... you need the binaries that match your Linux architecture, whichever it is. –  Joe Internet Aug 20 '11 at 20:12
    
Updated my answer to reflect that. –  Dave Aug 20 '11 at 20:27
    
@Dave I'd say it might be worth leaving it, since the error message you got didn't really tell you the problem someone else might fall into the same trap. –  Col Aug 21 '11 at 8:05
    
@Dave - Just make sure to answer your question so people know it's been solved. –  Shauna Aug 24 '11 at 13:54

Not the answer you're looking for? Browse other questions tagged or ask your own question.