Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've recently switched to FF7 through the Aurora PPA on KUbuntu. For whatever reason, they've decided to start removing http:// from the address bar:

Missing http

Whenever I edit a link (so that I can paste it in a question or answer here on Stack Exchange) the http:// is missing when I go to paste it!?!! I've searched through the preferences. I can't find anything that will undo it -- short of going back to the non-beta browser. I've also google searched for this and oddly enough the only thing I could find was a request to enable this behavior, asked here on Server Fault. That said, I really wanted to keep using FF7 on the computers I maintain because of its greatly improved memory performance.

share|improve this question

migrated from Aug 20 '11 at 8:22

This question came from our site for system and network administrators.

I should note that Chrome also hides http://, however it has a special semantic - when you select and copy any initial part of the URL, it will add http:// to the resulting paste. I suggest you ask the Firefox devs to do the same. – Ambroz Bizjak Aug 20 '11 at 9:35
Yes - you should file a bug report at . – Guss Aug 20 '11 at 9:38
up vote 15 down vote accepted

Go into about:config, set browser.urlbar.trimURLs to false

share|improve this answer
Thank you Chad!! – M. Tibbits Aug 20 '11 at 11:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .