Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm not a big fan of Google Chrome / Chromium, but I prefer it as my major browser. In most cases Chrome is able to do everything I need while browsing. Sometimes it is also able to infuriate me making me switch to another browser. I've noticed that after some long-term period (at least from my point of view) Chrome no longer opens e.g. some Google Docs documents/spreadsheets because of the error page with the following message:

Error 310 (net::ERR_TOO_MANY_REDIRECTS)

Then the number of such documents grows -- they all become unavailable. I was trying to clean up the whole cache of Chrome, and it didn't help. I also remember that creating a new local Chrome profile can help. But why should I remove the profile, then recreate it again, and wait few weeks until Chrome starts the buggy behavior again?.. I cannot figure out what is the reason of the bug. I usually use Chrome Canary builds (15.x.x.x currently), but this bug is alive for the last 6 or more months, so I guess it's still in the stable version of Chrome

Is there some way to fix it and possibly prevent it in the future?

P.S. I could not sign in to Super User from Chrome, and now I'm under Firefox, because I prefer OpenID authentication -- obviously it gets a lot of redirects error either while trying to log in using Google OpenID.

UPD: I guess it comes with Google profiles -- when suddenly there is no way to access some Google document from home, then the same document becomes unavailable anymore e.g. from office.

UPD2: A month later I lost the interest for Chrome. Removed it completely since I can't even access my Gmail. I don't really care for the solution at the moment, but it would be nice if someone answers - I'm really curious what's wrong.

share|improve this question

2 Answers 2

up vote 0 down vote accepted

It's normally connected to SSL False Start feature. More information is available here. Easy way to disable is to put --disable-ssl-false-start at the Chrome command line.

share|improve this answer

Clear all google.com cookies and clear the cache,that solves the problem

share|improve this answer
    
Thanks for the reply. As I mentioned above, it happens for the same profile from any location. Obviously, clearing cookies does not help in this case. –  Lyubomyr Shaydariv Dec 29 '11 at 16:35
    
@LyubomyrShaydariv I had the same issue but it was resolved when I cleared the cache. –  HackToHell Dec 30 '11 at 7:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.