Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have this problem that Windows 7 Ultimate automatically resets my color scheme from Aero to basic at random moments. What could possibly be the cause of this?


  • Intel core i7-930 @3.0GHz
  • XFX Ati Radeon HD5850 1GB GDDR5
  • ASUS P6T SE Motherboard
  • 6GB DDR3 RAM @ 1900Mhz

Windows says that the performance of my computer is not good enough for "Aero", but if this were true, I can't imagine what computer you need to use Windows 7 with Aero :)

share|improve this question
Win 7 seems to revert to the basic UI when running some programs that use the GPU. In my case this is mostly games however Maya and photoshop both use the GPU extensively. I'm not aware of any solution but this my help you narrow your search. – Lamar B Aug 22 '11 at 20:49
You have run the Windows 7 Experience Index, right? I don't know why it would revert at random times, but this allows Windows to know that your computer should be able to run Aero fine. If it doesn't pass the Index, it won't allow Aero to be turned on. – Ben Richards Aug 22 '11 at 20:55
up vote 2 down vote accepted

Since it happens using multiple GPU-intensive productivity apps simultaneously, perhaps you're overrunning the capabilities of the graphics card or system memory, even though you seem to have plenty.

In Photoshop CS5, go to Edit > Preferences > Performance and tweak some of the settings. The ones I would try are reducing the memory usage, disabling OpenGL Drawing, and perhaps reducing the Cache Levels. I'm not familiar with Maya but maybe it has similar settings to use fewer RAM or GPU resources.

share|improve this answer
I guess this could be the only solution then. Well thanks a lot for all the help. – Joris Aug 23 '11 at 20:19

I suspect that this is a problem with your graphics card drivers. Check to make sure that you have the latest version (run the latest version installer just to be sure).

share|improve this answer
Also, if you decide to reinstall your drivers, make sure you completely remove/uninstall any drivers you have installed for your graphics card already, before installing the new ones. – Ben Richards Aug 20 '11 at 22:03
I'm going to check this out now. – Joris Aug 20 '11 at 23:26
I have installed the latest drivers, now let's wait a few days for results... – Joris Aug 20 '11 at 23:39
This did not work out. Still have the problem. – Joris Aug 21 '11 at 21:01

Check for any background processes that may be trying to display something that's incompatible with Aero. Perhaps a third party screen saver, wallpaper switcher, or some other older program that may not be totally compatible with Windows 7.

share|improve this answer
Checking it out now... – Joris Aug 21 '11 at 21:02
I've checked for background processes, but I don't think that's the reason behind it. Often when I have opened a lot of programs that suck a lot memory, this happens. But the only programs I use are Maya 2011 and Photoshop CS5... But then I still don't understand because of my specs. – Joris Aug 22 '11 at 16:24

Windows Vista informs you at the tray with a balloon window when an application is incompatible with Aero. Does it occur after a full screen application/game or totally random?

Windows Event Logs might help, examine the logs, if there is no tray notification.

Better search for Aero incompatible applications.. Many reasons are there: ie, The Windows Aero feature may work incorrectly when you start a Java program that uses an earlier version of the Java Runtime Environment (JRE)

share|improve this answer
It happens on random moments indeed. But often it happens when I'm using programs like Maya, Photoshop and Skype at the same time. – Joris Aug 22 '11 at 16:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .