Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to set up my computer so I can remote access it from anywhere including outside the local network.

I have it working locally by following this tutorial but it was old in XP era. But now I'm using Windows 7.

What I'm doing wrong here? Or am I missing something?

What I have tried so far:

I know I need to forward the RDP port to 3389 on the router, but I'm not so sure if I'm doing it right. But here is what I did:

  1. I went to and get myself a domain name
  2. I download the DynDNS updater on my host computer so I can use the DNS rather than my IP address (I can ping my newly registered so I assuming I got that right)
  3. I went to my router admin page setup the port forwarding table to 3389 with my private IP address like this:

    D-Link Air G Plus Advanced options screen

All the remote desktop services are running and it works fine in my local network

But I when I try to connect I get the error:

Remote Desktop Errors

share|improve this question
Does it work if you enter your internet IP address? Is the IP address on the target computer reserved/static? – stukelly Aug 30 '09 at 22:55
it works when I enter my local private IP address, I got 2 PC here, so when I enter from the other PC it works. But when I try to use it doesn't work :( – Jonathan Aug 31 '09 at 0:24
the IP is dynamic at the moment, not static or reserved – Jonathan Aug 31 '09 at 0:25
From outside your LAN, have you tried to connect using your internet IP address? The issue may be with the dyndns service. – firedfly Aug 31 '09 at 2:58
@firedfly from outside using my neighbor's Wif I can ping to – Jonathan Aug 31 '09 at 3:00
up vote 2 down vote accepted

As the remote desktop is working internally, the problem must be between the computer and router.

First I would test the port is open using Can You See Me or telnet. If you receive no response, then have a look at the routers firewall settings, it maybe blocking the incoming connection.

One other possibility is your ISP maybe blocking port 3389.

share|improve this answer

If you are trying to use the from the LAN side of the router, many routers can't resolve the WAN Side of the router from inside the LAN. It's like picking up the phone and dialing your own phone number. Try using a friend or family members computer to remote connect and see if it works from outside.

share|improve this answer
I tried that using my neighbor's Wifi – Jonathan Aug 31 '09 at 2:09

Have you checked the firewall on the Windows 7 computer to make sure it allows remote connections from the internet. On my computer I have three profiles for connections when setting up the firewall: Domain, Private and Public. If the port is not open for the Public profile, that may explain the issue.

share|improve this answer
Yes I enabled them both Private and Public in the Windows Firewall – Jonathan Aug 31 '09 at 3:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .