Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to set up my computer so I can remote access it from anywhere including outside the local network.

I have it working locally by following this tutorial but it was old in XP era. But now I'm using Windows 7.

What I'm doing wrong here? Or am I missing something?

What I have tried so far:

I know I need to forward the RDP port to 3389 on the router, but I'm not so sure if I'm doing it right. But here is what I did:

  1. I went to http://www.dyndns.com/ and get myself a domain name
  2. I download the DynDNS updater on my host computer so I can use the DNS rather than my IP address (I can ping my newly registered xxxx.selfip.com so I assuming I got that right)
  3. I went to my router admin page setup the port forwarding table to 3389 with my private IP address like this:

    D-Link Air G Plus Advanced options screen

All the remote desktop services are running and it works fine in my local network

But I when I try to connect I get the error:

Remote Desktop Errors

share|improve this question
    
Does it work if you enter your internet IP address? Is the IP address on the target computer reserved/static? –  stukelly Aug 30 '09 at 22:55
    
it works when I enter my local private IP address, I got 2 PC here, so when I enter 192.168.0.102 from the other PC it works. But when I try to use xxxx.selfip.net it doesn't work :( –  Jonathan Aug 31 '09 at 0:24
    
the IP is dynamic at the moment, not static or reserved –  Jonathan Aug 31 '09 at 0:25
    
From outside your LAN, have you tried to connect using your internet IP address? The issue may be with the dyndns service. –  firedfly Aug 31 '09 at 2:58
    
@firedfly from outside using my neighbor's Wif I can ping to xxx.selfip.net –  Jonathan Aug 31 '09 at 3:00
add comment

3 Answers

up vote 2 down vote accepted

As the remote desktop is working internally, the problem must be between the computer and router.

First I would test the port is open using Can You See Me or telnet. If you receive no response, then have a look at the routers firewall settings, it maybe blocking the incoming connection.

One other possibility is your ISP maybe blocking port 3389.

share|improve this answer
add comment

If you are trying to use the xxxx.selfip.net from the LAN side of the router, many routers can't resolve the WAN Side of the router from inside the LAN. It's like picking up the phone and dialing your own phone number. Try using a friend or family members computer to remote connect and see if it works from outside.

share|improve this answer
    
I tried that using my neighbor's Wifi –  Jonathan Aug 31 '09 at 2:09
add comment

Have you checked the firewall on the Windows 7 computer to make sure it allows remote connections from the internet. On my computer I have three profiles for connections when setting up the firewall: Domain, Private and Public. If the port is not open for the Public profile, that may explain the issue.

share|improve this answer
    
Yes I enabled them both Private and Public in the Windows Firewall –  Jonathan Aug 31 '09 at 3:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.