Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I use Outlook Express on WXP with SP3. I'd been trying different email clients that associated .eml files with them, and eventually used folder options to change the association back to OE. At first, the files opened normally, but after a short while the entire program started loading instead of the file. If I associate .eml files with the other email client still on my computer, it works fine. Why this is happening, and how do I fix it?

share|improve this question

Possibly there is a missing parameter in the registry and just only application starts, not the clicked .eml files. The exact commandline shoud be:

"fullpath\to\outlookexpress.EXE" /eml "%1

Default; it would be:

"C:\Program Files\Outlook Express\MSIMN.EXE" /eml:%1

or

"C:\Program Files\Outlook Express\MSIMN.EXE" /eml "%1"

Notice the /eml parameter, it might be missing in your registry.

If EML files will not open in Outlook Express, try the following:

Open My Computer. Select Folder Options from the Tools menu. Click the File Types tab. Under Registered file types, select EML Outlook Express Mail Message, then click Advanced. Click Open, then click Edit. Type the following line in the "Application used to perform action" box: "C:\Program Files\Outlook Express\MSIMN.EXE" /eml:%1 Click OK twice, then close the window.

share|improve this answer
    
Adding /eml to the command line in edit file type worked - thanks! – Philbert Aug 21 '11 at 4:36
    
Welcome! And then please mark as "Anser" to help others. – Nime Cloud Aug 21 '11 at 13:36

Try re-installing OE:

msimn /reg
regsvr32 urlmon.dll
regsvr32 mshtml.dll
regsvr32 shdocvw.dll 
regsvr32 browseui.dll 
regsvr32 msjava.dll
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .