Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I type into Firefox, it brings up a window that asks for the username and password. The default for this router (Linksys WRT54G) is admin, admin. However, the network is unsecured, and I can't find a way in!

any questions, please ask.


share|improve this question
We need more clarification to your question. What does "the network is unsecured and I can't find a way in!" mean? Also, can you use Internet Explorer to get to the config page? Can you plug in a network cable to get into it? –  EvilChookie Aug 30 '09 at 23:57
What steps did you use to reset it? Was it plugged in while doing this? Did the front lights blink after doing it? What kind of evidence is there to show that it was actually reset? –  Joe Philllips Aug 31 '09 at 0:06

5 Answers 5

up vote 1 down vote accepted

This answer may suck, but someone may have saved your default firmware with a different admin password. Hence, a "factory reset" will just set it back to whatever they set it with. Unfortunately, if this is the case, you'll need a new box

share|improve this answer
what about putting in a new firmware like tomato? –  studiohack Aug 31 '09 at 0:03
Do it, if you can. I assumed you wouldn't be able to as you haven't tried it already. This would fix your issue –  Ciaran Aug 31 '09 at 0:09

You can reset the router to factory default.

enter image description here

However keep in mind that ALL settings will be default and you may have to reconfigure the router according to your ISPs requirements.

share|improve this answer
  1. Make sure you have a wired connection to the router from the computer you're using for access. Wireless routers cannot be configured wirelessly this way.

  2. If you're getting a login, but the known combo isn't working, perform a reset as Molly illustrated above.

  3. If you're still not getting anywhere, try another port.

  4. If you're still not getting anywhere - the router could be going south. Especially if you bypass it and all works well with the Cable/DSL modem only.

share|improve this answer

I believe the default is no username, pwd admin. You should connect to it via a wired connection.

If resetting the box doesn't work, try reinstalling the latest firmware from Linksys.

share|improve this answer
that is correct. –  Molly7244 Aug 30 '09 at 22:46
i have tried everything, admin/admin, blank/admin, admin/blank! –  studiohack Aug 30 '09 at 22:47
well, then reset the router, but remember, ALL settings will be set to default. –  Molly7244 Aug 30 '09 at 23:15
I have already tried to reset the router –  studiohack Aug 31 '09 at 0:04
what do you mean 'tried'? did you or did you net reset it? another question: are you using still the original firmware or an open source replacement? –  Molly7244 Aug 31 '09 at 6:25

Have you installed an alternative firmware on it? If so, then the default password would change to whatever the firmware you installed uses. For example DD-WRT uses root/admin.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.