Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using VLC 1.1.7 on Mac OS X 10.6.8 for listening to MP3s stored on my NAS, which is a QNAP device. My MacBook Pro is connected via Gigabit LAN over a Linksys WRT-610N router.

Problem:

Every file I play lags every minute or so. There's a short delay or glitch, then it continues to play. How can I get VLC to stream them correctly? Can I enable some buffer?

Things I've checked:

  • It plays local files fine without a problem
  • The network connection itself is not the issue (the NAS streams HD movies to a TV just fine)
  • It occurs on both SMB and AFP mounted shares
share|improve this question
up vote 8 down vote accepted

It is possible that the values for file cache times are too low. To be on the safe side, the buffer can be made larger.

Go to Preferences and navigate to the Input / Codecs tab. Click the Show All button.

Ensure Input and Codecs is selected in the sidebar and scroll way down to the Advanced section. In Network caching slider, enter larger values than the default ones. I found 1000ms for Local and 3000ms for Network to be sane. If you still see stuttering, try progressively larger values until playback is smooth.

Click the Save button. It might be necessary to restart VLC. Now you don't have any playback problems anymore.

share|improve this answer
    
any idea where this open has gone too? It's not present in 2.1.5 version of VLC. – Mark Tomlin Jan 19 '15 at 7:40
    
@MarkTomlin The option is now resides under Input / Codecs directly as of 2.1.5. – jibiel Feb 15 '15 at 0:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .