Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I start my Ubuntu Guest OS in the VM, a stream of errors fly by and here's what I see at the end.

mount: mounting /dev on /root/dev failed: No such file or directory
mount: mounting /sys on /root/sys failed: No such file or directory
mount: mounting /proc on /root/proc failed: No such file or directory
Target filesystem doesn't have /sbin/init.
No init found. Try passing init= bootarg.


BusyBox v1.13.3 (Ubuntu 1:1.13.3-1ubuntu11) built-in shell (ash)
Enter 'help' for a list of built-in commands.

(initramfs)

My host system is Windows XP, my guest system is Ubuntu 10.04 with Guest Additions and my VirtualBox version is 4.0.12.

I created a second VM and remounted the existing hard disk "Ubuntu 10.vdi" as the boot drive and got the exact same error. From searching around the internet, it seems I might be able to repair the drive, but I don't know how to do it from Windows XP or another Ubuntu VM.

share|improve this question

migrated from stackoverflow.com Aug 21 '11 at 11:36

This question came from our site for professional and enthusiast programmers.

1 Answer 1

up vote 1 down vote accepted

I have solved the problem, thanks to my buddy John who told me the approach: Use the ISO as a virtual drive so you have a working system to fix the broken virtual drive. So here's what I did.

  1. Added my Ubuntu 10.04 ISO file as a CD/DVD drive in my existing Machine.
  2. Switched the boot order to boot from CD/DVD drive first (I had to remove the VirtualBox add-ons ISO from machine as a IDE Controller drive, it was getting in the way).
  3. Started the machine and selected the option to try Ubuntu without installing and it showed the desktop.
  4. In a terminal window, ran sudo gparted and the broken partition showed up on the list along with others.
  5. Added a task to check/fix the partition and then ran the task.
  6. Shutdown the machine, switched the order back to boot from HD first, CD/DVD drive.
  7. Booted up the machine and Ubuntu is working again.

TBD if I lost anything at all but doing better than before :)

share|improve this answer
    
How do you add task to check/fix the partition? Is this done from inside gparted? –  windyjonas Mar 9 '12 at 10:07
    
This doesnt work for me since it says partition is already busy... –  darxsys Apr 7 at 8:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.