Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Mac OS X Lion introduced a new feature where in many applications you can press Command-Control-D to produce a popup with the definition for the word under the mouse cursor. A side effect of this is that you can no longer use the same shortcut to access functionality in other applications (for example, Emacs).

Is it possible to either

a) disable the word definition Command-Control-D keyboard shortcut, or
b) change the word definition keyboard shortcut to something other than Command-Control-D?

share|improve this question
    
Thanks for checking, Lri. For what it's worth, I looked in com.apple.symbolichotkeys.plist. No dice. –  Zane Shelby Aug 22 '11 at 19:48
add comment

3 Answers

I just figured this out, using the great research available here: http://hintsforums.macworld.com/showthread.php?t=114785

Note that I'm using 2 different definitions of "dictionary" in the explanation below:

The trick is to add a value to the AppleSymbolicHotKeys dictionary in com.apple.symbolichotkeys

Within this dictionary, you want to add a new dictionary for key 70 (that's word at point dictionary lookup) with enabled = NO. Make sure that 'enabled' is a boolean.

Unfortunately, I can't seem to distill it to a single 'defaults write...' invocation. It would be something like this:

defaults write com.apple.symbolichotkeys AppleSymbolicHotKeys -dict-add 70 "{enabled=NO;}"

but I can't figure out how to specify that 'enabled' should be boolean. As written, this makes it a string, which just doesn't work to disable the keystroke. You can run this command, and then edit the plist and switch it to boolean.. that may be easier than editing the file directly.

This will disable the dictionary keystroke. You can use the information from the link above to rebind dictionary to a different key if you prefer.

share|improve this answer
4  
The value can also be XML: defaults write com.apple.symbolichotkeys AppleSymbolicHotKeys -dict-add 70 '<dict><key>enabled</key><false/></dict>'. –  Lri Dec 7 '12 at 15:05
1  
Yey! (thanks @craig & @Lauri) just needed to restart! –  nhed Mar 23 '13 at 2:56
add comment

(First, this certainly isn't new — it's been around since Leopard, I belive.)

Unfortunately, it doesn't look like there's currently a way to disable or change it in Lion. You can add/change a shortcut for the "Look Up in Dictionary" Service, but this doesn't change the behavior of control-command-D. File a bug if you have a developer account, and for now, learn to live with it :(

share|improve this answer
1  
In Snow Leopard the global shortcut didn't 'shadow' or override application shortcuts. –  Zane Shelby Aug 22 '11 at 6:22
    
True. Yes, this is a disappointing behavior. It doesn't really bother me because I actually use control-command-D to look up words. –  jtbandes Aug 22 '11 at 6:24
add comment

This can be disabled.

In System Preferences, you can change and disable keyboard shortcuts. Go to System Preferences > Keyboard and select the Keyboard Shortcuts tab. Click the Services entry, and scroll down to the Searching section. Uncheck the Look Up in Dictionary to disable it, or double click the space to the right to change the shortcut.

share|improve this answer
    
It doesn't disable ⌃⌘D at least in 10.8.2. –  Lri Nov 29 '12 at 8:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.