Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've bought an external hard drive. I want to use it with Ubuntu 11.04 (kernel 2.6.38-11-server) and the zfs-fuse package. I've successfully formatted the disk to zfs. The disk is suspending when it is inactive after a while.

The problem is that zfs can't access the disk after I manually resume it. I can use sudo zpool clear after the resume, but it's not really a solution for me.

There is set usbcore.autosuspend=-1 in grub – I can see in a file /sys/module/usbcore/parameters/autosuspend that its value is set to -1 – but it doesn't work.

How can I correctly disable autoresume? Or is it possible to create a "hook script" that will detach zfs devices before they are suspended and attach the zfs devices after resuming the disk?

share|improve this question

migrated from serverfault.com Aug 22 '11 at 10:49

This question came from our site for system and network administrators.

Don't use zfs-fuse, it's outdated. Use the modules from zfsonlinux.org - with Ubuntu, just add the ppa from Darik Horn for native zfs for Ubuntu:

https://launchpad.net/~zfs-native/+archive/stable

This gives you ubuntu-zfs - Native ZFS filesystem metapackage for Ubuntu.

Follow instructions and FAQ from zfsonlinux.org/faq.html . For zfs automount, it's 1.14 in the FAQ.

I'm currently typing this on a zfs system which hibernates and suspends without issues.

share|improve this answer

You must log in to answer this question.