Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I start up Outlook 2007, and sometimes while it's running, I get the following message:

Cannot add to the server Junk E-mail Lists, you are over the size allowed on the server. The Junk E-mail Filter on the server will be disabled until your Junk E-mail Lists have been reduced to the size allowed on the server.

Would you like to manage your Junk E-mail Lists now?

Manage Lists... Cancel

The first time this error occurred I had only one entry in my "Blocked Senders" list from several months ago, which I have since removed. The "Safe Senders" and "Safe Recipients" lists are also empty, as are my "Blocked Top-Level Domain List" and my "Blocked Encodings List". I cannot disable Junk E-mail filtering, it is greyed out in the options. The option "Also trust e-mail from my Contacts" is selected in the Safe Senders tab of the options.

Is there any way I can prevent Outlook from attempting to add whatever lists these are to the server? Is there any other way to fix this? It's probably not a server problem since no one else is encountering this, and I'd prefer a quick client-side fix over going through IT anyways. I believe the server is running Exchange 2007, and there are no other clients in use, set up, or supported besides my BlackBerry.

share|improve this question
    
Are you using Microsoft Exchange? Are you using IMAP POP3? Are you using Outlook Web Access? –  wizlog Aug 22 '11 at 15:30
    
@wizlog Updated, and also solved by Tom. –  Matthew Read Aug 22 '11 at 15:34
add comment

1 Answer

up vote 1 down vote accepted

The option "Also trust e-mail from my Contacts" is what makes the "Safe Senders" list exceed the total limit.

You can try changing the limit of the junk e-mail lists, listed at the bottom of the page.

By default, you have the following limit on the total size of the junk e-mail lists:

  • Exchange: 512 kb (cumulative for all lists combined)
  • POP3/IMAP: none

Therefore, if you are using these lists extensively with an Exchange mailbox, you might hit the 512 KB limit.

Registry key: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem
Value: Max Extended Rule Size
Type: DWORD
Data: maximum size, in bytes, you want to allow for the junk e-mail rule

As you can see, "Max Extended Rule" applies to all rules and not just junk rules.

share|improve this answer
1  
Thanks Tom, unchecking that option seems to have fixed it. I probably should have tried it myself, but I was really hoping it wasn't necessary. –  Matthew Read Aug 22 '11 at 15:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.