Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This issue happens on XP SP3 and on Win7 SP1. The service is configured to run using a service account to logon as a service. When I manually enter the password it is accepted and is given logon as a service right. Then once the computer is rebooted the service does not start due to no password saved.

below is the error

Event ID 7041
service was unable to log on as contoso\$serviceaccount with the currently configured password due to the following error: 
Logon failure: the user has not been granted the requested logon type at this computer.

This service account does not have the required user right "Log on as a service."
share|improve this question

migrated from serverfault.com Aug 22 '11 at 18:07

This question came from our site for system and network administrators.

2 Answers 2

My problem was that I had, not sure why, logon as a service defined at the domain level which was stepping on the service after every reboot. I added the domain service account to the domain group policy that was setting the logon as a service, did a gpupdate /force and was able to start the service.

share|improve this answer

You need to grant that account the "log on as a service" right.

(on your domain controller)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.