Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to set up an old XP Pro system I was using at work as a small home file server, but my Win7 box can't access it - I get "Invalid User or Password" error - and I see the following on the XP's Security event log:

Login Failure:

Reason: Unknown user name or bad password
User Name: MediaUser
Domain: MUSICBOX
Logon Type: 3
Logon Process: NtLmSsp
Authentication Package: MICROSOFT_AUTHENTICATION_PACKAGE_V1_0
Workstation Name: BEOWULF

system stats are:

Server

name: MUSICBOX

OS: XP 32-bit SP3

Able to ping and Remote Desktop to that system from the client, but no UNC access.

Client

name: BEOWULF

OS: Win7 Home Premium 64-bit

I'm specifying a valid "MUSICBOX\MediaUser" account and password - it works for Remote Desktop, but is rejected by SMB.

MediaUser has admin rights on the XP box. MUSICBOX and BEOWULF live on the same workgroup.

Ideas?

share|improve this question
add comment

3 Answers

Possible cause: Win7 uses NTLMv2 authentication, while XP defaults to accepting NTLM.

On XP, run secpol.msc. Go to Security Settings → Local Policies → Security Options, find the "Network security: LAN Manager authentication level" option, and set it to the "Send NTLMv2 response only\refuse LM and NTLM" level.

(Alternatively, you could lower the authentication level on Win7 to "Send NTLM" – it's your LAN, your security requirements.)

Another post on SuperUser says the problem could be caused by large clock differences.

See also the Microsoft document Windows 7 and HomeGroup Downlevel Sharing.

share|improve this answer
    
Thanks for the suggestions, but none of them did anything helpful. I figured it out. –  Eli Aug 23 '11 at 16:55
add comment
up vote 1 down vote accepted

Weird.

None of the above suggestions worked. I read the document linked above, and saw that MS suggested "Simple File Sharing" - well it WAS on, so I turned it OFF.

And that worked - I have full access to the shares now.

Maybe because the system was once on a domain, and now it is off of it.

Again, weird.

share|improve this answer
    
This worked for me too, and the system at hand was never on a domain. –  Gabe Sep 2 '11 at 23:19
add comment

Did you try setting up a user on EACH computer that is exactly the same, with the same username and password and permissions? Say, set up Poweruser with ** as the password (substitute an actual password) with Limited permissions (the same on each.) User accounts can be created by an administrator or any user with administrator rights in Control panel. This worked for me.

If you have multiple XP and Windows 7 computers, set up this username and password the same on all of them. THEN check each file or folder which is not working properly for any restricted sharing permissions on the drive of each computer. Some users may have blocked access to, say "my pictures" for anyone but themselves. The "all users" or shared user folders contents should already be visible.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.