Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I started my computer today without being able to connect to the internet for some very odd reason. As the title says, that is the name of problem that Network and Sharing Center says on Win7.

It is weird though, because every time I troubleshoot the problem it cycles through two answers. One time it will be the name of the problem above, and the next time it will say that my perfectly fine Ethernet cable is not properly plugged in or may be broken. It also showed a 3rd problem, saying my Realteak PCIe GBE Family Controller (gigabyte Ethernet card) was bad so I reinstalled that and the error went away but not the problem.

I'm running Windows 7 64bit and connecting to the internet through a Ethernet cable obviously. My Linksys router is fine, and I'm using another computer in the house to type up this problem here.

> ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : Luke-WIN7-PC
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Realtek RTL8168D/8111D Family PCI-E Gigab
it Ethernet NIC (NDIS 6.20)
   Physical Address. . . . . . . . . : 48-5B-39-45-13-87
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::69e4:a47c:962d:10f7%11(Preferred)
   Autoconfiguration IPv4 Address. . : 169.254.16.247(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.0.0
   Default Gateway . . . . . . . . . :
   DHCPv6 IAID . . . . . . . . . . . : 189291321
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-15-E4-B3-2B-48-5B-39-45-13-87

   DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                       fec0:0:0:ffff::2%1
                                       fec0:0:0:ffff::3%1
   NetBIOS over Tcpip. . . . . . . . : Enabled
share|improve this question
3  
from a CMD prompt, please cute and paste the output of ipconfig /all –  Keltari Aug 22 '11 at 23:20
    
I added it to the question. –  Luke oX Aug 23 '11 at 11:05
2  
DHCP seems broken from what I see... –  Tom Wijsman Aug 23 '11 at 11:12
    
What should I do? –  Luke oX Aug 23 '11 at 20:22

2 Answers 2

Both IPv4 and IPv6 have standard methods for address autoconfiguration. For link-local addressing IPv4 uses the special block 169.254.0.0/16 as described in RFC 3927 while IPv6 hosts use the prefix fe80::/10.

Most IPv4 hosts use link-local addressing (IPv4LL) only as a last resort when a DHCP server is unavailable. An IPv4 host otherwise uses its DHCP-assigned address for all communications, global or link-local. One reason is that IPv4 hosts are not required to support multiple addresses per interface, although many do. Another is that not every IPv4 host implements distributed name resolution (e.g., multicast DNS), so discovering the autoconfigured link-local address of another host on the network can be difficult. However, discovering the DHCP-assigned address of another host also requires either distributed name resolution or a unicast DNS server with this information, and some networks feature DNS servers that are automatically updated with DHCP-assigned host and address information.

share|improve this answer

Do you have other computers to test this with? You should try to determine whether this is your router that is malfunctioning or whether it is your computer that has new recent problems.

For your router, you could try to install the latest firmware and when necessary try to reset/reconfigure it to make sure it's back in business. Make sure that DHCP is set up well, or you would need to give your computer it's own static IP address.

For your computer, try obtaining the latest network drivers and make sure the cable is properly connected. Resetting the adapter as well reinstalling any installed firewalls might or might not give a difference. As said before, if DHCP is somehow broken, you might consider want to use a static IP...

share|improve this answer
2  
a tcpdump on port 67 might also be useful to see what is going on with DHCP. –  MaQleod Aug 22 '11 at 23:32
    
All the other computers are connecting to my network wirelessly fine. My Xbox connects fine through ethernet to my router as well. I tried setting up a static IP but I need to be connected to the network which I can't do. –  Luke oX Aug 23 '11 at 11:08
    
@Luke: You don't need an actual connection to be able to configure the static IP. –  Tom Wijsman Aug 23 '11 at 11:10
    
From the tutorial on portforward I needed to be connected so I could change he network adapter settings. –  Luke oX Aug 23 '11 at 20:26
    
@LukeoX: Not necessary, you can change these with the cable plugged out... –  Tom Wijsman Aug 23 '11 at 20:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.