Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am having problems on my Laptop with Symantec, its a very strange problem -

Interface lags, and mouse is jerky at almost random time intervals. I did a bit of digging and it seems that no matter what program I'm currently working in - Firefox, Outlook etc... it says its using massive amounts of CPU - 60 -> 70% and smc.exe, WmiprvSE.exe and svchost.exe are up near the top too.

A bit more digging found that the service running in the svchost.exe process was netsvcs.

Using process monitor I looked at what smc.exe was doing and found that its making massive amounts of registry calls. 174,000 in 2 minutes - compared to 20,000 on another machine with very similar set up.

The keys its accessing are the TCPIP settings (i think...) of the network interfaces : HKLM\System\CurrentControlSet\services\Tcpip\Parameters\Interfaces

Some of the keys its trying to access don't exist. If i copy large amounts of network data then my computer slows dramatically. I have reinstalled Symantec twice, removed unused network connections in windows, uninstalled winpcap, tried a reg clean and also tried resetting the TCP/IP stack in windows. I have to concede a loss on this one.... Any ideas what is causing the performance issues, and what I can do to fix (without a rebuild).

Notes:

  • Symantec Endpoint provided by company.
  • Others in company are not experiencing the problem.
share|improve this question
    
Upon re-reading this -- Have you tried updating your drivers? Specifically your network adapter driver? Maybe there's a newer version that plays nicer with whatever Symantec's client is doing. –  Ƭᴇcʜιᴇ007 Aug 23 '11 at 13:57

1 Answer 1

That's Symantec for you!

I hope you get an answer able to actually fix/address this individual issue, but, I doubt it.

Generally speaking, the business tools are better, but, I have seen nothing but problems with Symantec products of recent years and with the exception of Backup Exec, I do not sell any of their products any more.

This is the sort of problem I used to see all the time when supporting it and the only solution I can really suggest is to swap vendors and try another anti virus solution.

You may hate it now, but, it will be for the best in the long run.

share|improve this answer
    
Unfortunately I work for quite a large company and we recently switched the whole business from McAfee to Symantec. Generally its working fine, but not on my laptop... I have so many programs I have installed and configured I really want to avoid a rebuild. I'm not 100% sure it symantec, it may be the underlying windows architecture as I have a .NET program I have developed to do network sweeps that was working fine but started going slow and locking my laptop a bit. I only just remembered, I wonder if a faulty network card could cause problems like this? –  leinad13 Aug 23 '11 at 11:40
    
@Leinad13 - Fair enough! It is most likely network related - maybe try adding your program to the firewall white list? :/ however, I really can't say for certain. –  William Hilsum Aug 23 '11 at 11:44
    
@leinad13 If it's a recent company-installed version then the person that implemented it may have gone over-board with the settings (i.e. heuristic scanning on every file you touch). They should be also able to do things like skip files over 200MB (example size), etc. to reduce CPU usage. This kind of stuff is not Symantec-specific, but Symantec is awesome at suggesting you turn on/up every setting. :) –  Ƭᴇcʜιᴇ007 Aug 23 '11 at 12:18
    
@techie007 - Could be this but I doubt it, as my laptop is one of the more powerful and is the only machine suffering. I had a helpful "just reinstall it" from the guy who implemented symantec. I'm going to go back to him soon, to be honest I get better support on SuperUser than I do from some of our core IT teams. –  leinad13 Aug 23 '11 at 12:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.