Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For some reason I cannot type a pipe(|) symbol with US keyboard in Ubuntu while I can do it in Windows 7 which also uses US keyboard. Normally I use left-shift with the button next to it to type a pipe symbol, but in Ubuntu it creates < and > with shift (like "shift+," and "shift+." are already doing).

share|improve this question

4 Answers 4

up vote 0 down vote accepted

try "shift" + "some key next to enter". I have on my us keyboard two pipe keys - one next to left shift and one right above the enter key.

share|improve this answer

I fixed this for my Dell keyboard by running

sudo dpkg-reconfigure keyboard-configuration

and selecting the most similar keyboard (SK-7100, I think - my actual keyboard is a SK-8165) and guessing sensible options for the other questions (in my case, UK layout, extended-winkeys, no compose).

This was for Ubuntu Server 12.04 LTS 64-bit on VMWare 4.04, host: Windows 7 64-bit.

share|improve this answer
    
this one worked for me. –  virpara Apr 11 '13 at 14:32
    
This also worked for me – slightly hard to believe that you still need to do this in Ubuntu in 2014! Thank you. –  lukescammell Jul 17 at 9:41
1  
And you have to it after every kernel update –  Andrew Fielden Oct 10 at 9:39
    
@AndrewFielden Thanks, that's a shame but useful to know! Might be possible to automate it - see stackoverflow.com/questions/8671308/… –  DNA Oct 10 at 10:01

Try this

  1. Hold down the ALT key
  2. Enter 1,2,4 on the numeric keyboard (you might need to activate it via the Num Locktoggle key)
  3. Release the ALT key

Hope this helps

share|improve this answer

If you can’t type pipe (|) then change keyboard layout

command is : setxkbmap us

It's work for me

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.