Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to connect to this online radio station (it is in Thai) using VLC:
http://www2.mcot.net/radio/fm_1005.asx

For some reason, when I connect using Firefox or IE (IE just dumps me over to Windows Media Player), it works just fine.

But when I connect using VLC it tells me:

Your input can't be opened:
VLC is unable to open the MRL 'mms://www2.mcot.net/radio/fm_1005'. Check the log for more details.

When I look at the log it says this:

access_mms error : failed to open a connection (tcp)  
access_mms error: cannot connect to server  
main debug: net: connecting to mediai.mcot.net port 80  
main debug: connection succeeded (socket = 2136)  
access_mms error: error: HTTP/1.1 404 Not Found  
main debug: no access module matching "mms" could be loaded  
main debug: TIMER module_need() : 11058.001 ms   
            - Total 11058.001 ms / 1 intvls (Avg 11058.000 ms)  
main debug: waitpipe: object killed  
main error: open of `mms://mediai.mcot.net/fm1005' failed: (null)

How can I get this station to work in VLC? (Or failing that, what is different about this station that makes it not work in VLC?)

share|improve this question
    
Hi @Vaccano Do you mean VLC media player? This may be a bit too localised if it only relates to one site - especially as it may just be a problem with that site. Can you use your app to open streams from elsewhere?. –  Linker3000 Aug 23 '11 at 15:40
    
I can open other streams in VCL Media Player. But not this one. It is just weird because all the other apps can open it. VCL is supposed to be the app that can play anything. And it is the only one that does not work. –  Vaccano Aug 23 '11 at 15:45
    
I'll edit your question to VLC. This may be a problem with the site then if VLC works for everything else. –  Linker3000 Aug 23 '11 at 15:50
    
Just FYI - I have found a thread elsewhere, dated March 2011, relating to VLC not working with a station's radio stream + mms errors and the 'fix' was: "We have just updated to Windows Media Codec v9 at the station's encoder, which seems to have solved the issue of the stream not playing in VLC." –  Linker3000 Aug 23 '11 at 16:05
add comment

2 Answers

up vote 1 down vote accepted

I've tried this, and it works:

rtsp://mediai.mcot.net/fm1005

Reference:

http://forum.videolan.org/viewtopic.php?f=14&t=77738

share|improve this answer
add comment

The error message indicates that your particular install of VLC doesn't support the MMS streaming protocol. Where did you download it? Try the main site, http://videolan.org, if you haven't already.

share|improve this answer
    
Yeah, I wondered about that too. Before I opened the question I went there and got the latest version (1.1.11) and tried with that. –  Vaccano Aug 23 '11 at 15:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.