Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Linux system running (Debian). It is working perfectly from a remote point of view. I can ssh in it, it has the imap running correctly, and a couple of kvm systems running (I can also ssh to them). Well, it works!

But when I go in front of the keyboard/mouse/screen there's nothing. No way to switch between the consoles with Ctrl+Alt+F# (X is not running on this system). The screen is desperately black. But the screen does not go to sleep mode, it still has its green led on! I guess it means that the graphics card still sends the H and V syncs correctly (VGA connection).

Is there a process that is blocking the display and prevents me from getting the control?

What's happening?

Note: Last time I used the console, it was in console 1. Ctrl+Alt+F1.

share|improve this question
add comment

3 Answers

To diagnose, some things I would try: turn off screen blanking, ssh in and see if any suspicious processes are visible in top/htop, restart getty from an ssh session, check syslog, check daemon.log. Also simply try unplugging and replugging the keyboard if it's USB.

share|improve this answer
    
Thanks CarIF, "turn off screen blanking" failed. "ssh in" shows me the bash running in the console, killed it unsuccessfully. "syslog" and "daemon.log" don't show anything unusual. Already "unplugged" the PS/2 keyboard/mouse. –  Didier Trosset Aug 24 '11 at 15:39
    
How about restarting getty? I'm wondering about a hardware fault. Can you try a different keyboard/mouse? –  CarlF Aug 24 '11 at 16:24
    
Restarted all 6 getty processes. Still the same. Keyboard/Mouse is OK, they are used in a KMV switch that works perfectly for other systems. –  Didier Trosset Aug 24 '11 at 16:29
    
Could still be a bad cable, but I'm conceding this is really unlikely. Have you tried another *monitor*/monitor cable? If the monitor is detecting signal but showing nothing, it's very possible it's either faulty or not receiving the (VGA?) signal correctly. –  CarlF Aug 24 '11 at 16:36
    
Oh: I've had problems in the past with bad ports on a KVM. Can you try directly plugging in, or a different set of ports? –  CarlF Aug 24 '11 at 16:57
add comment

I sometimes have a similar problem on an Ubuntu 8.04 machine, and do this:

ctrl-alt-F2 (for instance) to switch to another console, wait a couple of seconds, then ctrl-alt-F7 to switch back to the GUI.

In particular it seems to happen on the login screen, where moving the mouse or pressing a key doesn't seem able to wake up the screensaver sometimes.

OFF-TOPIC UPDATE: For anyone who's arrived here searching for X solutions, I tracked down the fix I had to do to get the ctrl-alt-F# keys to work in Ubuntu 8. Some edits to xorg.conf, that I'd blogged about here: http://darrendev.blogspot.com/2009/04/screen-keeps-going-blank.html

share|improve this answer
    
Thanks Darren. I already tried switching consoles, being very patient. –  Didier Trosset Aug 24 '11 at 13:25
    
I know there was one machine (I think it was that Ubuntu 8 machine actually) where the ctrl-alt-F# functionality was not built-in, but needed installing! Another idea is, from your ssh session, try killing X. Perhaps it just died of boredom and a young, fresh X instance will be more responsive? –  Darren Cook Aug 24 '11 at 13:29
    
X is not even running on this machine ... It is only a console issue! –  Didier Trosset Aug 24 '11 at 14:47
    
@Didier Trosset Ah! Sorry, I missed that it was console-only. I only ever get a similar problem with X/gnome. –  Darren Cook Aug 25 '11 at 2:19
add comment

changing the foreground terminal by means of chvt often works for me

# chvt 1
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.