Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When trying to install Windows 7 Professional 64bit SP1, after the language select and click "Install", I get the missing drivers message. I don't have the exact wording, but it's along the lines of:

device drivers are missing for storage devices, please insert media and browse to driver location.

This happens at the beginning of install.

  • The processor is an ASUS P8P67 Rev. B3
  • I have tried all the drivers from disk provided with the motherboard, no luck.
  • In the BIOS, I have tried, RAID, AHCI and IDE, all with no luck.
  • The BIOS shows that I have two 500GB HDDs, and diskpart in the Windows installer shows me the same.

I have tried all the SATA connectors (White SATA 3) (Light Blue SATA 2) and (dark blue marvell SATA 3) but still have no clue.

share|improve this question

migrated from Aug 24 '11 at 11:28

This question came from our site for system and network administrators.

IDE mode in the bios should get it installed, are you sure you saved the changes when exiting the bios?, also be sure the sata port the hard drive is on is enabled, some bios's have the ability to disable sata ports individually. Please post he motherboard model and revision numbers. – Moab Aug 24 '11 at 16:27

Check if your hard drives are using the GUID Partition Table (GPT) instead of the MBR/Basic one. If there are already any partitions on then (and u don't need the info on them if any) delete them using the diskpart utility (Shift+F10). Or try activating UEFI Boot.

share|improve this answer
up vote 0 down vote accepted

Turned out that trying to install it from a USB configured by a Microsoft application to be bootable and allow the installer to run was causing a problem.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .