Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I need to copy files via ssh but I am getting permission denied.

How can I log as a root by windows clients such us FileZilla/WinSCP?

I try execute command:

sudo su, but I am getting error: You must have tty to run sudo.

I try to resolve this error but without luck.

share|improve this question

migrated from serverfault.com Aug 24 '11 at 13:37

This question came from our site for system and network administrators.

    
A little trick is you can use /tmp as a temporary place and then move the files from it, beware of security and space limitations though. – Shadok Aug 24 '11 at 13:27
    
For WinSCP, see How to change user in winSCP? – Martin Prikryl May 21 '14 at 6:20

What the basic problem here is that there is a protection again non-human input. TTY ensures that the action is performed from keyboard actions, and not from another program. Now there is a way around this.

If you have access to the sodeors file you can deal with this. It is not really recommended but here goes, this is really a way that works.

You open the file /etc/sudoers and you find the following line:

Defaults:myusername    !requiretty

This tells the the system that the user myusername can perform non-keyboard actions. Now you can work with all your files using the sudo command.

Best is to try to avoid this.

share|improve this answer
    
Once you setup the requiretty flag as this answer explains, follow this guide to setup WinSCP to use sudo: winscp.net/eng/docs/faq_su – Martin Prikryl May 21 '14 at 6:29

With WinSCP, check the "Avanced Options" box. In the Environnement>SFTP section, select the "sudo su -c /bin/sftp-server" option.

Indeed, your SSH server has to be configured to allow you lauchning such command.

share|improve this answer
    
For more details, see winscp.net/eng/docs/faq_su – Martin Prikryl May 21 '14 at 6:21
    
This does not answer the question, which is about a problem with tty. – Martin Prikryl May 21 '14 at 6:28

You have to consider to log in as your root user on the server rather than using su or sudo, this could be done by username or password or via a key file. However, the server should allow you to do this; if not, there is not much that you can do to remotely gain root acces...

share|improve this answer
    
I logged in by key/username which I get from my boss, but it gives me nothing at all, I can't copy files at all – drupality Aug 24 '11 at 12:52

When dealing with Amazon Web Services and WinSCP the adjusting the sudoers keyboard input status does not work because WinSCP continues to throw a SSH command that AWS does not understand and will give a bash error.

I was having the same problem and solved it using the steps in this tutorial:

How to Login in as SSH root user from WinSCP to AWS

enter image description here

enter image description here

enter image description here

share|improve this answer
    
You could post the summary without screenshots. Posting just a link is not a good practice. – Olli Mar 6 '14 at 13:26
    
Turning off keyboard-interactive authentication is irrelevant, imho. It has nothing to do with TTY. And it affects SSH authentication phase only. sudo's turn is only after SSH authentication phase. Read about keyboard-interactive authentication‌​. – Martin Prikryl May 21 '14 at 6:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .