Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I restart my computer I don't want the apps that were open to relaunch. I've disabled "Restore windows when quitting and re-opening app" but that doesn't help on a restart. How can I do it?

share|improve this question
You mean the "Reopen windows when logging back in" in the prompt that shows up when restarting right? – Vervious Aug 24 '11 at 23:31
I don't get any prompt on restart. All I am trying to achieve is on restart only my login items open. i.e. I don't want Eclipse, iTunes etc all launching taking forever and a day. – henry.oswald Aug 26 '11 at 15:39
You don't get the "Are you sure you want to restart your computer now?" prompt? Did you disable it or something because everyone should get that. . . – Vervious Aug 26 '11 at 20:39
I get asked if I want to restart my computer. I don't get asked if I want all my applications to auto load up again. – henry.oswald Aug 27 '11 at 12:48
up vote 1 down vote accepted

This isn't quite an answer, but just double checking:

enter image description here

You don't get the check box that asks you if you want to reopen your windows or not?

share|improve this answer
Is there a way to make not reopening the windows the default behaviour? – Nerian Oct 1 '11 at 20:33
Not with Apple provided functionality. A quick Google does yield this though… – Vervious Oct 2 '11 at 0:13

Another thing you should check is the login items. Go to System Preferences -> Accounts -> choose yours ->login items. Delete those you don't want to open items.

share|improve this answer
The login items are usually inconsequential compared to OS X Lion's saved application states because login items are rarer, and usually user set; but still, you have a point. – Vervious Aug 25 '11 at 22:56
thank im happy with my login items, its the things that aren't in my login items which were open prior to the restart that are frustrating me. e.g. eclipse launches because I had it open before the restart. – henry.oswald Aug 26 '11 at 15:42
Has changed to System Preferences -> Users and Groups -> choose yours -> login items. – vaichidrewar Jul 22 '15 at 1:37

The solution or workaround is quite simple and just included in the system.

With the Finder, just put a copy of the /System/Library/PreferencePanes/StartupDisk.prefPane (or an alias of it with the name you like) in the dock.

If you follow me well, you will see that, with this method you can restart your computer in three clicks, exactly the same amount of clicks to restart it from the menu, and one less than you would have to do to restart with disabling "Reopen Windows at Login" by un-checking the option. Even better because if you have several start disks, you don’t need to use anything else to choose the one you want to restart to.

No need for scripts, commands or queer things, just included in the system.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .