Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to download gcc using apt-get install on Ubuntu 9.04 Jaunty, but when apt-get is trying to download the file I receive an error:

WARNING: The following packages cannot be authenticated!   
libc6 libc6-i686 binutils libgomp1 gcc-4.3 gcc linux-libc-dev libc6-dev Install these packages without verification [y/N]? y 

Err http://mt.archive.ubuntu.com jaunty-updates/main libc6 2.9-4ubuntu6.3  404 Not Found [IP: 91.189.88.30 80] 
Err http://mt.archive.ubuntu.com jaunty/main binutils 2.19.1-0ubuntu3   404 Not Found [IP: 91.189.88.30 80] 
Err http://mt.archive.ubuntu.com jaunty/main libgomp1 4.3.3-5ubuntu4   404 Not Found [IP: 91.189.88.30 80] 
Err http://mt.archive.ubuntu.com jaunty/main gcc-4.3 4.3.3-5ubuntu4   404 Not Found [IP: 91.189.88.30 80] 
Err http://mt.archive.ubuntu.com jaunty/main gcc 4:4.3.3-1ubuntu1   404 Not Found [IP: 91.189.88.30 80] 
Err http://security.ubuntu.com jaunty-security/main libc6 2.9-4ubuntu6.3   404 Not Found [IP: 91.189.92.166 80] 
Err http://security.ubuntu.com jaunty-security/main libc6-i686 2.9-4ubuntu6.3   404 Not Found [IP: 91.189.92.166 80] 
Err http://security.ubuntu.com jaunty-security/main linux-libc-dev 2.6.28-19.66   404 Not Found [IP: 91.189.92.166 80] 
Err http://security.ubuntu.com jaunty-security/main libc6-dev 2.9-4ubuntu6.3   404 Not Found [IP: 91.189.92.166 80] 

Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/g/glibc/libc6_2.9-4ubuntu6.3_i386.deb 404 Not Found [IP: 91.189.92.166 80] 
Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/g/glibc/libc6-i686_2.9-4ubuntu6.3_i386.deb 404 Not Found [IP: 91.189.92.166 80] 
Failed to fetch http://mt.archive.ubuntu.com/ubuntu/pool/main/b/binutils/binutils_2.19.1-0ubuntu3_i386.deb 404 Not Found [IP: 91.189.88.30 80] 
Failed to fetch http://mt.archive.ubuntu.com/ubuntu/pool/main/g/gcc-4.3/libgomp1_4.3.3-5ubuntu4_i386.deb 404 Not Found [IP: 91.189.88.30 80] 
Failed to fetch http://mt.archive.ubuntu.com/ubuntu/pool/main/g/gcc-4.3/gcc-4.3_4.3.3-5ubuntu4_i386.deb 404 Not Found [IP: 91.189.88.30 80] 
Failed to fetch http://mt.archive.ubuntu.com/ubuntu/pool/main/g/gcc-defaults/gcc_4.3.3-1ubuntu1_i386.deb 404 Not Found [IP: 91.189.88.30 80] 
Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/l/linux/linux-libc-dev_2.6.28-19.66_i386.deb 404 Not Found [IP: 91.189.92.166 80] 
Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/g/glibc/libc6-dev_2.9-4ubuntu6.3_i386.deb 404 Not Found [IP: 91.189.92.166 80] 

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

apt-get update and --fix-missing are not solving the problem.

How can I solve it?

share|improve this question

migrated from stackoverflow.com Aug 24 '11 at 15:02

This question came from our site for professional and enthusiast programmers.

add comment

4 Answers

I managed to solved the problem by editing the /etc/apt/sources.list file and replacing all instances of archive.ubuntu.com and security.ubuntu.com with old-releases.ubuntu.com. After that, I ran sudo apt-get update to update the indexes.

share|improve this answer
    
Perfect! Thanks. –  Scott Radcliff May 3 '13 at 20:46
add comment

This little script performs the correct string replacements in sources.list and updates the package list:

cd /etc/apt
sudo cp sources.list sources.list.bak
sudo sed -i "s/archive./old-releases./g" sources.list
sudo sed -i "s/\/security./\/old-releases./g" sources.list
sudo apt-get update
share|improve this answer
add comment

See here: http://mt.archive.ubuntu.com/ubuntu/dists/ – Jaunty is missing.

Your Version of Ubuntu is too old. The Jaunty repository is not more available. I think you need to upgrade to a newer version of Ubuntu.

share|improve this answer
    
Is it possible to keep the same ubuntu version jaunty, and update the url of the repository of apt-get to a newer version to be able to download the deb files? –  DreX Aug 24 '11 at 13:29
    
@DreX Yes its possible, but no really good idea. The problem are Dependences. App X need glic >=2.10 or app Y needs >qt4.6 etc. –  krzym Aug 24 '11 at 14:03
    
@DreX maybe you will want install only small depen app, then can do it :) –  krzym Aug 24 '11 at 14:09
    
@DreX - You'll want to use an LTS version for the longest support times. –  Joe Internet Aug 24 '11 at 15:13
add comment

I managed to solve it by (re)moving the multiarch dpkg config file, re-installing dpgk, then trying an upgrade..

Fails:

sudo apt-get upgrade

Fails:

sudo apt-get install dpkg
sudo apt-get upgrade

Succeeds:

sudo mv /etc/dpkg/dpkg.cfg.d/multiarch /etc/dpkg/dpkg.cfg.d/multiarch.backup
sudo apt-get install dpkg
sudo apt-get upgrade
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.