Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The default Windows XP logon screen seems to no longer be functioning. I'm presented with a logon box asking for my username and password - I can still log in, but I wish to restore the old method.

I've tried the following:

  • Toggled Welcome Screen and Fast User Switching in Control Panel, it had no effect.
  • Ran control userpasswords2 and toggled both Users must enter ... and Require users to press ...
  • Ran system file checker: sfc /scannow, there were no problems.
  • Verified the Fast User Switching Compatibility service is up and running (services.msc).
  • Checked the Terminal Services service for good measure.
  • Checked the Event Viewer for relevant issues, there were none.
  • Verified there's no GinaDLL entry at HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon.
  • Verified HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\LogonType is set to 1.
  • Verified HKLM\SOFTWARE\Microsoft\Windows NT\Current Version\Winlogon\AllowMultipleTSSessions is set to 1.
  • Imported the Restore Fast User Switching registry file from kellys-korner-xp.com (which includes AllowMultipleTSSessions as above).
  • Checked if HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\system was possibly overriding the above.
  • Ran XP_FixLogon.exe from dougknox.com to verify the default standard Gina was in use.
  • Getting desperate: double checked stats of gina files: dir *gina* /p/s/a (even after SFC verified them).
  • Getting desperate: used NirSoft's RegScanner to search for strings containing gina in the registry looking for something suspicious.
share|improve this question
    
Did you try pushing CTRL + ALT + DEL twice? –  ta.speot.is Sep 11 '11 at 4:26
    
@todda Actually yes. :) –  Christopher Galpin Sep 11 '11 at 8:24

2 Answers 2

up vote 5 down vote accepted

After scouring the web and all of the above failed, I tried Logon Loader Recovery Tool 1.0 (link to softpedia as it's no longer hosted on author's website) from Daniel Milner.

Success! The author has informed me his tool sets the following registry value: HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\UIHost to logonui.exe

share|improve this answer
    
+1 for posting the solution here as this may be helpful to others. –  Randolf Richardson Aug 25 '11 at 2:51

You just need to Enable the "Fast user switching"

see: http://www.addictivetips.com/windows-tips/how-to-enable-disable-fast-user-switching-in-windows-xp-and-windows-vista/

share|improve this answer
1  
Hi Rabin. This is incorrect for this particular question, as it says in the question that was the first thing I tried. The correct answer for this question was that the UIHost registry value was set incorrectly. (I asked and self-answered it to help others.) –  Christopher Galpin Mar 25 at 8:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.