Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just installed MySQL Workbench 5.2 and everything went well. But I can't manage to start it. It shows no error message, and no splash screen.

I've tried to troubleshoot compatibility, but with no success.

Any thoughts?

share|improve this question
From I experience, I have found this to be a buggy pieced of software. however, have you any previous versions of Workbench installed? – slotishtype Aug 25 '11 at 10:45
No, its a fresh install of windows. – Gabriel Solomon Aug 25 '11 at 13:10
get Visual C++ 2010 redistributable x32 & NET Framework 4 Client Profile x64 – user100707 Oct 8 '11 at 21:20
+1 for x32 version of C++ 2010, even if you are running a x64 PC – klonq Nov 19 '13 at 15:12
up vote 2 down vote accepted

I saw in the Event Viewer that this application causes a fault in KERNELBASE.dll (Id = 1000).

Install an older version (mysql-workbench-oss-5.0.30-win32.msi), and this is working.

I have Win 7 Home Premium.

share|improve this answer

Installing the 32 bits version of Visual C++ redistributables (vcredist_x86.exe), even if you use Windows 7 Pro x64, should fix the problem.

share|improve this answer
This worked for me using 5.2.47 version, thanks – Castro Roy Jul 30 '13 at 13:06

Uninstall .NET Framework 4 Client Profile and Visual C++ redistributables (I had a bunch) from your computer (using Programs and Features) and re-install the most recent .NET Framework 4 Client Profile and Visual C++ 2010 redistributable.

I had the same problem using Windows 7 64-bit and I fixed it this way.

share|improve this answer

Fresh install of WB 5.2.35 CE and Visual C++ 2010 redistributable x86, no other changes, hacks or installs (or reinstalls) did the trick for me.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .