Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a 3000 GB Seagate Barracuda XT sata drive. It originally came in an external enclosure with a removable USB 3.0 interface as part of the Seagate GoFlex series of drives. When using this externally it worked like a charm and showed 1 partition which read as ~3tb. When the drive was removed from the enclosure and installed internally no partitions were seen by Windows 7 x64, but initializing the disk w/GPT and partitioning + formatting proved to provide a useful 3tb drive once again.

The drive has now shifted into yet another computer (internally) but no data on it seems to be accessible. The drive shows in a similar state as to when I first removed it from the enclosure initially and installed it internally: blank, waiting to be initialized w/GPT and partitions added and formatted.

Is there any hope in recovering this data or am I in a canoe without a paddle?

Thank you in advance for any tips!

Additional stuff I've tried:

  1. booting ubuntu x64 11.04 with sata set to IDE reveals only my smaller drives in the system, the 3tb drive doesn't show anywhere by default.

  2. tossed this drive into an old HP that's kicking around running W7 x64, it also does not see any partitions or data but shows the drive waiting to be initialized.

  3. connected to the external (original) GoFlex adapter via USB doesn't reveal any usable partitions to the naked eye. Windows picks up the drive and says it needs to be initialized.

Edit: I'm waiting on some parts to see if I can get the original motherboard it was connected to (and working) up and running again. Until further notice I'm without that hardware though. :(

share|improve this question
add comment

3 Answers 3

up vote 2 down vote accepted

The enclosure was there to abstract away a common problem among 3TB drives

Without formatting to a GPT, the current partition table and thus the max size of a partition is limited to ~ 2TB (assuming 512 sectors).

Formatting as a GPT allows a single 3TB partition (called volumes in GPT speak).

Drives formatted as GPT must be initialized however before they can be used, which is why you could not see the drive without Windows initializing the disk. You don't need to reformat the drive everytime, just initialize it.

Easiest way to initialize a disk is by going into Computer management and double clicking Disk Configuration and right clicking the drive to be initialized.

share|improve this answer
    
Thank you kindly for your tips here! I've extremely worried 'initialize disk' will overwrite something important. It asks if I want MBR or GPT on the dialog box which makes me think it's going to re-write how the disk manages files. Will this overwrite my data or perhaps I'm looking in the wrong spot? –  Matt Aug 25 '11 at 18:07
    
In other news I decided to click on 'initialize' and now it registers as 2794.39 GB Unallocated. Slightly worried I've crossed the line here... :S –  Matt Aug 25 '11 at 18:19
add comment

I know that some BIOS will struggle with drives 2tb or larger, have you checked to see if yours is compatible.

share|improve this answer
    
All three boards + external enclosure seem to function fine with the drive. The problem comes in to play when you move the drive from one to the other. Keeping it in one computer, initialized as GPT + a ~3tb partition is no issue for the host computer. You just can't move it to another PC. I think it has something to do with how things are being emulated differently across the different boards but I can't be certain yet. I did end up getting my data back from a backup but I'd still love to know what exactly happened. Thanks for the tidbit! –  Matt Aug 27 '11 at 3:30
add comment

Seen the same problem but only from switching into an external docking station. the thing is, a usb 2.0 dock reads the drive except one or two folders were not accessible, which may just have got corrupted or be a HDD problem

but then I try in a new USB 3.0 dock and it says drive needs to be initialized! put back in the usb 2.0 dock and it shows up again, now it's error checking though

i previously would just load it in an sata connector internally in a PC where it was initialized as GPT to have one 3TB partition. all OS on the PC's are Windows 7 64-bit

maybe one is professional and the other is home premium though

share|improve this answer
1  
The version of Windows should not matter in that aspect –  Simon Sheehan Mar 6 '12 at 21:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.