Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a MacBook Pro 15" i7, Snow Leopard 10.6.8.

Files won't "drop" after dragging them.

I've restarted my computer several times, and repaired disk permissions as well as verified the disk – and the results told me my MacBook Pro was fine.

What should I do? What's causing this?

share|improve this question
    
What happens instead? Does it snap back? Sometimes it may stick and you have to click to drop. Does that work? –  digitxp Aug 25 '11 at 20:01
    
Where are you actually trying to drag/drop files from/to? –  slhck Aug 25 '11 at 20:25
    
Double click to drop if you have Drag Lock on. –  Vervious Aug 26 '11 at 1:07
    
thanks guys. what happened was, my computer worked fine before, i don't have drag lock on, so it should automatically drop to another folder like if i dragged from my desktop to photos. it didn't drop. it was stuck moving around with the cursor. when i press esc, it wouldn't snap back to the desktop. –  Laurice Aug 26 '11 at 6:48
    
So you use the trackpad only? How do you perform the drag then? Do you have "dragging" enabled (i.e. double-click, then drag) or do you click the pad and drag? Or is your problem solved? –  slhck Aug 26 '11 at 7:15

3 Answers 3

An anonymous user posted the following as a suggested edit to one of the answers to this question:

This seems to be related to Avatron's Air Display, see this post.

From the linked web page:

Here’s the current status: IF you’re running Lion AND if you have an NVIDIA 9400M/9600M chipset AND you have a third-party video driver installed, THEN you will not be able to release the mouse button while drag-dropping something.

Well, it turns out that the drag-drop bug only manifests itself if you haven’t done a Wake From Sleep since your last Log In or Restart. So there’s a workaround: After each Log In or Restart, close your MacBook Pro, wait for it to sleep, and then open it again to wake it. It’s a little bit of a pain, but it’s there as a workaround if you want to use Air Display on one of these Macs.

share|improve this answer

Open System Preferences » Trackpad and make sure you don't have Drag Lock set there.

share|improve this answer
    
Is there even a difference between Drag Lock activated and the default setting? Couldn't spot any. –  slhck Aug 25 '11 at 21:20
    
@slhck Just watch the video. You can remove your fingers while dragging. It's gone on Lion, so I cannot experiment myself /// Totally off topic: May I send you an SU blog post draft by email for feedback? –  Daniel Beck Aug 25 '11 at 21:28
    
Ah, so there's no automatic deactivation anymore. /// Why yes, I'll read through it some time tomorrow or over the weekend! –  slhck Aug 25 '11 at 21:32
1  
@Daniel Beck the drag lock setting is actually still there in lion, albeit in the Universal Access section buried underneath 2 layers of settings. –  Vervious Aug 26 '11 at 1:08
    
I don't have drag lock selected. It's probably something with my trackpad? thanks for the help though. –  Laurice Aug 26 '11 at 6:49

That happens to me in Lion after I boot my computer.

My solution: put it to sleep and wake it and everything will be ok

share|improve this answer

protected by Daniel Beck Jun 25 '12 at 17:49

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.