Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I type "15:45" or "21/12" openoffice Calc changes it to "15:45:00" and "21-12-2011".
How do I disable this globally and permanently?
I know you can use "Format cell..." and then select text, but I never ever want it to autocorrect dates/time.

share|improve this question

3 Answers 3

up vote 2 down vote accepted

This seems to be one of the most-disputed features of OOo.Calc. Calc needs to know whether to treat input as number or as text. It defaults to number, since it's main purpose is calculating stuff.

Up to now, AFAIK there are only two methods to preserve the literal string:

  1. Put an apostrophe (') before the string, telling Calc that the data following should be treated as a string;
  2. As already mentioned: use formatting to set the cell content to "text".

Depending on the user's needs, Solution 2 could be set to be the default:

  • change the "Default" style to text format (Menu Format -> Styles and Formatting -> right-click on Default -> Modify -> Numbers Tab),
  • save that spreadsheet as template,
  • and (optionally) set that customized template as default.

Of course, this has the disadvantage that every input will be treated as text, not as a number, in spreadsheets based on that template. So, a solution may be to prepare such a "text" spreadsheet as template, but not as default template. < EDIT >: another approach consists in creating an additional cell style with "text" formatting (see above). This reduces the effort required to toggle between numbers and text to changing the cell style. < / EDIT > I fear that's all available at the moment.

share|improve this answer

Go to format, then to cells, then change the options to what you want them to be. Although it may not completely stop autoformatting, it will work tons better than any other option such as formatting to "text".

share|improve this answer

This answer on StackOverflow offer a far better alternatibe :

http://stackoverflow.com/questions/13835264/how-to-prevent-openoffice-libreoffice-calc-from-changing-what-you-input-data-n

When you open the CSV, you face a dialog box that will permit you specifing the data type of each columns.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.