Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Is there any way to allow the classic "Ctrl-Apostrophe-E"-style combos, which input accented characters, work in any text box, rather than just in special programs like Wordpad or Microsoft Word?

share|improve this question
add comment

4 Answers

Autohotkey is always the answer.

http://www.autohotkey.com/forum/topic570.html

This script will allow you to enter a variety of characters in any program.

It's a long script to cut and past into the answer so I'll hold off. Basically, it allows you to use the same Microsoft Word hotkeys in any program.

share|improve this answer
    
Wow, no built-in solution in Windows? +1 for Autohotkey then, I guess that's a possible choice too. –  Mehrdad Aug 26 '11 at 3:19
    
@Mehrdad: IMO, Microsoft's position is understandable. Not all programs accept accent characters the same way. Some don't at all, so forcing them could introduce more bugs. –  surfasb Aug 26 '11 at 3:28
    
And for Linux there's AutoKey. –  Adobe Aug 26 '11 at 7:24
add comment

Open the Control Panel, Region and Language, Keybaords and Languages, Change keyboards...
Press Add. Select your language, and select Keyboard.
Tick Show More... Find and tick United States-International. Press OK.
Optionally, change the Default input language to your new keyboard. Press OK.
Press OK once more.

Now you should have a keyboard icon next to your system tray in the task bar. You can turn the feature on and off here. Now you can type any of these symbols, by typing punctuation before the letter. Capital letters work too.

' + c, e, y, u, i, o, a = ç, é, ý, ú, í, ó, á  
" + e, y, u, i, o, a    = ë, ÿ, ü, ï, ö, ä 
` + e, u, i, o, a       = è, ù, ì, ò, à 
~ + o, n, a             = õ, ñ, ã 
^ + e, u, i, o, a       = ê, û, î, ô, â 
share|improve this answer
    
These don't seem to work for me. What's the exact key combo? Did I miss a step? I tried Ctrl-` followed by e but didn't get è. –  Mehrdad Aug 26 '11 at 3:17
    
You don't press Ctrl. You just press punctuation, letter, one after the other. For example: typing 'e gives é. Think of it as typing smileys in a chat program. You just type :) and you get a smiley. Do you see a keyboard icon next to the system tray? When you click it, are there the options "US" and "United States-International"? –  Hand-E-Food Aug 26 '11 at 3:39
    
Oooh that's interesting. How do I type the symbol by itself though? Do I have to do T-H-A-T-'-<space>-S just to type in that's every time? –  Mehrdad Aug 26 '11 at 3:54
    
Only if the following character joins with the accent. Typing 's will show 's because there are no accents on s. The only word I can think of that will give you trouble is ma'am. Of course you'll need to watch out with "every" quoted string starting with a vowel. –  Hand-E-Food Aug 26 '11 at 4:09
    
But what about when I want to type a ` in something like the box here? There are more situations than contractions. –  Mehrdad Aug 26 '11 at 4:29
show 2 more comments

The Character Map program will let you do it in most text fields. win, type charmap

It can also be found in Accessories/System Tools

share|improve this answer
    
-1 how is this related to the key combo? –  Mehrdad Aug 26 '11 at 3:18
add comment

Personally, I save all the non-ascii chars I use frequently to a single text file - and copy/paste from there.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.