Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a wireless network setup using a AP541N Cisco wireless access point. I can connect to shares from Finder with cmd+K over AFP and SMB to the NAS and I can get to the internet, but thats it. None of the services that work over Bonjour are functioning, for example sharing my CD from my Mac Mini to my MacBook Air or Home Sharing in iTunes.

What do I need to do to get Bonjour to work over my wireless network?

Product Identifier:  AP541N-A-K9
Hardware Version:    V01
Software Version:    AP541N-K9-2.0(0)
Device Name:         AP541N-A-K9
Device Description:  802.11n Dual Band Access Point - Single Radio

My network looks like:

[inet] -> [CabelModem] -> [Time Capsule] -> [Switch] -> [AP541N] -> [Laptops/Phones]
                                                    \-> [Mac Mini]
                                                    \-> [Lacie NAS]

The Time Capsule is running as a Router for the CabelModem, the file sharing and the wireless are both turned off. It's providing DHCP for the entire network, the AP541N does not have DHCP.

share|improve this question

1 Answer 1

up vote 3 down vote accepted

There are several settings in the AP541N that could cause multicasts to fail, and since Bonjour is built on multicasts, it would make Bonjour fail as well. Here's how to set your settings to give multicast the best chance of working:

  1. Disable "Client Isolation". This setting intentionally keeps wireless devices from being able to talk to each other.
  2. Set the "DTIM Interval" to 1. The DTIM Interval is how often multicasts are delivered to power-save clients. All Apple wireless clients use power-save mode all the time.
  3. Set the "Fixed Multicast Rate" to the lowest rate (1?). In 802.11, multicasts are not ACKed or retransmitted, so you have to make sure to pick the lowest rate that all your devices can receive reliably.
  4. Leave your Supported Rates, Basic Rates, and MCS Indexes at their factory defaults.
  5. Use "Factory Defaults" or "WFA Defaults" for QoS settings.
  6. Disable "Multicast/Broadcast Rate Limiting".
  7. Temporarily turn off all wireless security as a test. If that makes a difference, then you have to start fiddling with security-related parameters to find the most secure settings that don't break multicast. Read on.
  8. Try disabling "Broadcast Key Refresh" by setting it to zero.
  9. Use WPA2-only, AES-CCMP only. Allowing multiple cipher suites causes multicasts to use a different cipher than unicasts, which sometimes causes interoperability problems.

By the way, unless that Time Capsule is the original "1st Generation" model from 2008, its wireless probably gives that AP541N a run for its money. The 2nd generation model from early 2009 added simultaneous dual-band with 2 spacial streams (up to 300 megabit/second performance) like the AP541N has. The 3rd generation model from late 2009 added 3x3:3 for up to 450 megabit per second performance, besting the AP541N. The 4th generation model that just came out in June 2011 is a more modern 3x3:3; it's still 450 megabits per second, but with optimizations that will give you better actual throughput (less overhead). And because Apple products make so much use of Bonjour, which is multicast, Apple does a better job than most at making sure multicast works reliably on their base stations.

share|improve this answer
    
I have a 2009 Time Capsule. I got the AP541N because I would lose signal (4 bars down to 1 bar) going into another room from where the Time Capsule was located. With the AP541N I don't have that issue. I would much rather have the better performance and easy of use of the Time Capsule but the reliability of the AP541N seems to be much better. –  Justin808 Aug 26 '11 at 20:18
    
@Justin808 so did you get Bonjour working? –  Spiff Aug 26 '11 at 20:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.