Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just bought a new top-of-the-range computer, and assembled it myself. Yesterday, I was playing on games fine. However, I tried to play on the same games and it failed to connect - this is for every game I try.

I've disabled my router firewall, my anti virus and windows defender. Nothing in any of their logs have anything to do with blocking connections. I can go open games' launchers, I can do everything on websites, but as soon as I try to connect to a game's server, it doesn't work.

I have several other computers using the same internet connection that work fine on the same games, so it's not an issue with the router (although I have tried resetting it). I can only think it is something to do with my computer and/or its wireless adapter, but as it was working yesterday and I haven't changed anything I can't think of a problem.

There was a brief error message after I reset the router for my computer when I tried to load the internet (something about DNS), but it was only for 3 minutes or so and I'm not sure if any of my other computers had the same problem or not.

I hope I've provided enough details for someone to fix the problem, I'm completely stuck :(

share|improve this question
    
Take a look in your hosts file (C:\WINDOWS\system32\drivers\etc\hosts) and and see if there are any entries other than the localhost entry. –  MBraedley Aug 26 '11 at 12:45
    
I was about to try that when a download for another game finished and started working. Intrigued, I tried my first game - it worked. It's back to normal, although I've absolutely no idea why. –  pighead10 Aug 26 '11 at 13:05
    
@Pig Head - This sounds like its a router configuration problem. It sounds like you are forwarding the ports as you would expect. the problem is you can only forward a port to a single address. On a side note it could also be your wireless adapter check the settings. –  Ramhound Aug 26 '11 at 14:22
    
can you ping the game server? which port is the game using? is it open? –  tumchaaditya Jun 14 '13 at 9:07
add comment

2 Answers

My son had a similar problem- solved when he discovered that Internet explorer had somehow gone into "offline mode". Try checking your I.E settings Hope this helps

share|improve this answer
add comment

Did you check your network connection performance? You can try to check it here -> http://www.netscan.co/

The Connectivity Checker will perform a series of network tests for modern Web Services like WebSockets and WebRTC. A unique url will be created with the results which you can then share with an expert to get your problem diagnosed.

It was helpful for me, I hope that it will be as helpful for you too.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.