Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My problem is with using google.

What is wrong?

My browser is Opera 11; Google Instant is turned off. Autocomplete is on. Experiment "Keyboard shortcuts" is active.

The same is for Chrome browser, but the jump is done when the autocompletion shows variants of query.

Update: There is something in Google's JS, which makes working with the search harder. So the question is: how to fix this google's bug? Should I turn something, (Experiment, Autocomplete, Suggests) or may I write a UserJS to make site working better in my browser?

In Chrome (the current version, 13.0.7xx) the experiment is turned off but bug is still there. Also, I can't find how to turn off Autocomplete/Suggest when I from Chrome.

How to reproduce with Chrome:

  • Go into "Anonymous mode" (ctrl-shift-n). In this mode there are no usual cookies set; google account is not logged in.
  • navigate to google.com, do a search.
  • By default the "Instant" feature is on. So, click gear at top-right; then "SearchSettings" (this will navigate you to http://www.google.com/preferences?hl=en )
  • Check the "Do not use Google Instant"; click "save preferences".
  • Enter some search, e.g "hoe to fix a linut". Press "Search".
  • Click on "hoe" just before 'e', press a letter "w"
  • Cursor will jump to end of string. No autocomplete will be shown.

OS: WinXP for chrome; linux for opera; Both x86 32 bit

== Update 2 ==

Reproduced with Firefox 6.0 on winxp32bit

share|improve this question
1  
Yes, I experience the same thing in Opera 11.5 having turned off Google Instant. The cursor jumps to the end having successfully typed a 'z' (or another letter) in the middle. This only happens immediately after having done a search, when you type the first character. Subsequent characters are OK. I have Opera set with default settings AFAIK. Where is "Autocomplete" settings? I have experimented with "Enable single-key shortcuts" (is this what you are referring to?) but it made no difference whether it was enabled or not. –  w3d Aug 26 '11 at 21:30
1  
@Tom: Yes, same for me in Google Chrome as well. Regardless of what state the autocompletion is in. I did reinstall Chrome 12 a few weeks ago as it happens (now on Chrome 13) and have it set to default as far as I'm aware. –  w3d Aug 26 '11 at 22:12
1  
So it doesn't happen with javascript off. I suspect that this is a bug. –  Vervious Aug 26 '11 at 22:23
1  
Reproducible in Lion 10.7.2 beta Safari Version 5.1 (7534.48.3) and Chrome 15.0.861.0 canary and Firefox 6.0 release with Google Instant off. Probably a Google bug and off topic on SuperUser. –  Vervious Aug 26 '11 at 23:54
2  
@Tom Wijsman agreed. –  Vervious Aug 27 '11 at 17:00

2 Answers 2

up vote 5 down vote accepted

To work around the issue, you can use the parameter complete=0 in the Google address to turn off Google's autocomplete.

In Opera, for example, you can make a bookmark to http://www.google.com/?complete=0 with nickname google. You can then go to the address box, type google, and press Enter to start a Google search session with autocomplete off.

Or you can go to Tools → Preferences → Search, edit the Google entry and add &complete=0 to the end of the address. Then the Google selection in Opera's search box will use Google with autocomplete off.


Test steps

I'm using Windows XP and Opera 10.1. I went to Google → Search Settings and turned off Google Instant.

I went to http://www.google.com/search?q=THIS+IS+VERY+UNIQUE+SEARCH+QUERY. When I clicked in the search box on the page and typed a letter, I could see the progress bar quickly flash in the address box indicating something was loaded. It seems that if I'm still holding a keyboard key down when the progress bar disappears, then the text cursor moves to the end of the search box.

If I go to http://www.google.com/search?q=THIS+IS+VERY+UNIQUE+SEARCH+QUERY&complete=0 then the bug no longer happens.

share|improve this answer
1  
but autocomplete is gone! :) –  Vervious Aug 27 '11 at 1:41
    
But autocomplete is not useful in most cases; also it will spy on user (which keys are pressed, what was entered into search field). I think, this may be the solution of problem. –  osgx Aug 27 '11 at 6:14
1  
@osgx: Autocomplete is certainly useful, it allows you to determine if you still need to provide extra query words on the fly or if the current query words already provided you an useful link. It prevents that you have to Type -> Search -> Type -> Search and wait for those individual Searches, with Google Instant it's as simple as Type -> Type and you end up spending less time on the search. A work-around is just avoidance of the problem and is nowhere near a solution. Just entering google.com requires you to add ?complete=0 or you are forced to enter the search box, that's a loss of time. –  Tom Wijsman Aug 27 '11 at 13:09
    
"Just entering google.com requires" me to press "Down arrow" key twice to focus on bookmark. Then google.com?complete=0 will be opened. –  osgx Aug 27 '11 at 13:14
    
@osgx: Now consider that you could instead enter your search terms right away... –  Tom Wijsman Aug 27 '11 at 17:06

I resolved this issue by disabling an 'auto-correct' 3rd party extension, which I had installed in Google Chrome. I haven't had this issue since I got rid of it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.