Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I used to be able to switch to iTunes using cmd-tab and press the space bar to pause a song as it was playing. This allowed me to to stop the song quickly when I was interrupted by a phone call.

However, this no longer works. I can only go to the Controls menu item in iTunes and select Controls --> Pause.

I do see that the menu item "Pause" is mapped to "space". When I press the space bar now with iTunes as the "active" application I just hear a tone. Recently I upgraded both Lion and iTunes so I am not quite sure which one stopped this from working properly.

Does anyone know how to get this functionality back?

share|improve this question
2  
I think this is a bug. –  Vervious Aug 26 '11 at 22:07
    
I have iTunes 10.4.1, no relevant custom shortcuts and the same issue when the iTunes main window isn't open. How did you solve your issue? –  Daniel Beck Sep 9 '11 at 15:27
    
@DanielBeck I edited my answer with an alternate solution that should work for you until this problem is fixed by Apple. –  Snap Shot Sep 18 '11 at 15:33
    
@SnapShot Actually, that solution is how I learned do it anyway (while also getting used to pressing F8 ;) ). Thanks for staying on this topic! –  Daniel Beck Sep 18 '11 at 16:26
    
To follow up on this question - this is now fixed in iTunes 10.5 –  Snap Shot Oct 13 '11 at 12:19
show 1 more comment

3 Answers

up vote 1 down vote accepted

This isn't common for most people that upgrade to Lion. All 5 macs I have checked didn't have the application shortcuts change and space still maps correctly to play/pause in iTunes.

enter image description here

Have you tried making a new user account or resetting your keyboard shortcuts to the defaults (and cleaning out any un-needed Application shortcuts after the upgrade? There have been several threads on where all sorts of system keyboard shortcuts didn't survive an upgrade. I don't know if this is some bug in the upgrade scripts or just that some damage that was harmless in the preference list files is now a problem in Lion.

Also, from reading the comments - make sure iTunes is the frontmost app with a proper window showing. If you need to pause the music when other apps are present - you might look into a special widget like Take Five.

share|improve this answer
    
Thanks for much for your help. Those are great suggestions. –  Snap Shot Sep 9 '11 at 13:37
    
This only occurs if there's no iTunes main window open. Clicking the menu item still works, but not pressing space. –  Daniel Beck Sep 9 '11 at 15:26
    
bmike, I appreciate your response, but if the menu item is visible, enabled, and has a keyboard shortcut independent from main window state, I expect its keyboard shortcut to work independent from main window state. Just like any other window/document independent menu item shortcut in any other application. It'd be different if the menu item were deactivated while the main window were closed, but it isn't. Clicking works when the iTunes main window is closed, pressing space doesn't. –  Daniel Beck Sep 9 '11 at 15:37
    
It's not clear to me at all that there aren't even two issues at play. It's fairly clear to me that it's not just an iTunes bug - I've gone to no less than 12 macs at various 10.7 / 10.7.1 and 10.4 / 10.4.1 and none of them are having this. I'm sure you have an issue - just not able to dissect it since things work in general for me. I hope someone has better ideas for your situation. I don't know if it's better at this point to ask another question referring to this and stating that the selected answer does not work for you and solicit additional ideas. –  bmike Sep 9 '11 at 15:49
add comment

This problem was fixed after I upgraded to iTunes 10.4.1 The update notes for 10.4.1 mentioned fixing a problem with media keys on third party keyboards. This was not exactly my problem because I saw this issue both on a Logitech keyboard and on the built in Macbook laptop keyboard. However, immediately after upgrading iTunes the space bar started working properly so perhaps there was a problem during the Lion upgrade that was fixed by the iTunes 10.4.1 update.

If upgrading does not work for you I can offer the following alternative.

First, this is only a problem if the if the main iTunes window is closed or minimized. You can follow the following steps to stop and start the music without using the mouse:

  1. cmd-tab to iTunes so it is the foreground application
  2. Press cmd-opt-1. This will bring up main iTunes window to the foreground
  3. Press the space bar to stop or start the music
  4. Press cmd-m to minimize the main iTunes window again

This involves one or two extra steps but it works well enough until this problem is fixed.

share|improve this answer
    
Awesome - sometimes it's nice for things to get fixed on their own rather than needing to figure it out. –  bmike Sep 9 '11 at 13:41
add comment

I have the same issue and it seems to have started after 'upgrading' to iTunes 10.5

At first i thought the spacebar no longer controlled play/pause but now what I see is happening is that iTunes is defaulting to the search field so when I switch to iTunes and hit the spacebar, iTunes searches for a 'space'... duh. Once I've clicked my library however, the spacebar resumes its playback control but that completely defeats the purpose of course. Lame.

share|improve this answer
add comment

protected by Daniel Beck Jan 8 '12 at 17:01

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.