Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Whenever I try to install Chrome, I get installer error 102. (It downloads successfully, though.) I'm using this installer from here.

An earlier version of Chrome installed and updated OK a long, long time ago on the same XP computer.

I tried following the instructions here, but they didn't seem to help.

share|improve this question
    
What exaclty happened when you ran the installer from the command-prompt after setting the tmp environment-variable? –  Synetech Aug 27 '11 at 1:55
    
@Synetech The exact same thing. It downloads, then gives me error 102 after downloading. (AFAIK) –  muntoo Aug 27 '11 at 1:57
    
I've made a post here: google.com/support/forum/p/Chrome/… –  muntoo Sep 3 '11 at 1:49
    
While you wait for find out what’s wrong and fix it, you could try manually unpacking the installer/.7z. –  Synetech Sep 3 '11 at 18:48
    
This error may also occur because of insufficient disk space. –  liammclennan Jan 17 '12 at 8:44
show 1 more comment

3 Answers

It looks like the problem isn’t with Chrome, but with Google Update. Something is blocking Google Update from download and/or installing Chrome (what you download was just a small stub, the actual installer is much larger).

Try installing with the offline installer (alternate) instead.

share|improve this answer
    
I the Google offline Standalone installer, but then I got "Installation failed. Google Chrome installer failed to start.". I tried fixing it using the best answer's directions, but the I got Error 102 again. I remember the Softpedia setup worked (for version 10?), but I had to move chrome.exe into a different directory, and do other workarounds. But then the built-in updater didn't work. –  muntoo Aug 27 '11 at 4:55
    
Then it definitely sounds like Google Update is getting messed up somehow. Try wiping out Chrome and Update by deleting their folders. (What OS are you running?) For example, delete both C:\Users\muntoo\AppData\Local\Google\Update and C:\Users\muntoo\AppData\Local\Google\Chrome\Application. (Stop the Google Update service first if it is running: net stop gupdate) Then use the offline installer (preferably the one from FileHippo since it directly installs Chrome, whereas the one from Google has a wrapper that first installs Google Update). –  Synetech Aug 27 '11 at 6:20
    
The gupdate service doesn't exist on my system. Is there any way to "install"/register it? –  muntoo Aug 28 '11 at 19:31
    
Filehippo's (14.0) installer doesn't even show a window. It starts for a few seconds, then the process terminates. Same with Softpedia's 13 stable. –  muntoo Aug 28 '11 at 19:41
    
Did you try erasing the directories I mentioned above? –  Synetech Aug 29 '11 at 0:54
show 7 more comments
up vote 2 down vote accepted

Well, for some odd reason, this worked for me for Chrome 15 Stable.

Put ChromeStandaloneSetup.exe inside C:\chrometemp\. Then, run cmd.exe:

cd\
cd chrometemp
set TMP=C:\chrometemp
set WINDIR=C:\WINDOWS
start ChromeStandaloneSetup.exe

See here.

share|improve this answer
    
cd\ cd chrometemp set TMP=C:\chrometemp set WINDIR=C:\WINDOWS start ChromeStandaloneSetup.exe Still not working, nothing helpful. –  user106094 Nov 20 '11 at 0:10
    
Well there you go. Like I said, you needed to make sure that the tmp variable is pointing to an existing folder with sufficient space before running the installer. I guess I didn’t make it clear that you needed to run the installer from the command prompt after doing so (so that the installer inherits the environment variable), but since it was valid, it should not have needed to be (ie, if the variable was correct in the system, then the installer should have worked from anywhere). –  Synetech Nov 20 '11 at 1:26
    
@Synetechinc. I could have sworn I already tried this, but it didn't work in Chrome <15. –  muntoo Nov 20 '11 at 1:29
1  
Chances are that when you ran the/an installer, it messed up the environment variables (at least until the next reboot), and so when you ran the installer again, it couldn’t find the temp folder. There’s something weird/bad about Windows in that regard. Whenever a WM_SETTINGCHANGE message is broadcast (as installers are wont to do), environment variables (especially those with other variables in them) suddenly stop resolving until reboot. Whenever this happens to me, I have to open a command prompt and manually set the tmp var to run some apps until I can get around to rebooting. :-| –  Synetech Nov 20 '11 at 1:32
add comment

Take a look here

Quick summary Check for "expand.exe" and or change the location of your temporary folder

share|improve this answer
    
Oh yes, I already tried that. Edited question. –  muntoo Aug 27 '11 at 1:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.