Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I was using Moneydance, a java-based application and when scrolling through an Income/Expense report with two fingers via the trackpad, many windows popped open. This is the same behavior as double clicking, and it happened for any item my cursor passed as I scrolled.

I started a bug report with Moneydance and was advised to try things with jEdit. I did and see that jEdit is picking up even resting two fingers on the trackpad as a click event of some sort.

This does not happen on an HP8540w running the same setup.

My setup:

  • Arch Linux x86_64
  • Macbook 2,1
  • xf86-input-synaptics version 1.4.1-1
  • xorg-server version
  • java 1.7.0


Section "InputClass"
    Identifier "touchpad catchall"
    Driver "synaptics"
    MatchIsTouchpad "on"
    MatchDevicePath "/dev/input/event*"
    Option "TapButton1" "1"
    Option "TapButton2" "2"
    Option "TapButton3" "3"            
    Option "VertEdgeScroll" "off"
    Option "VertTwoFingerScroll" "on"
    Option "HorizEdgeScroll" "off"
    Option "HorizTwoFingerScroll" "on"

Any suggestions? The touchpad works fine everywhere else... I'm really puzzled as to why java apps are having problems with it. I'm happy to provide more information; just request it.

share|improve this question
up vote 4 down vote accepted

From my experience disabling Horizontal scrolling fixes the issue for vertical scrolling. So you can

synclient HorizEdgeScroll=0 HorizTwoFingerScroll=0

to do this at runtime. Or to have it permanently disabled you can edit


setting options "HorizEdgeScroll" and "HorizTwoFingerScroll" to "off".

By the way, this is not related to particular Java application, it's the same for all of them (at least I assume so, seeing the same issue in jEdit, NetBeans and Moneydance). This is also not MacBook specific. I've had the same issue on my Dell XPS L702x laptop with Synaptics touchpad. JDK 1.6 and 1.7 versions, OS: OpenSUSE 12.1 x86_64.

share|improve this answer
I'll try this when I get home and get back to you; if it works, I can post on Arch Wiki as well. Thanks! – Hendy Dec 19 '11 at 14:12
Just tried it and that solves the issue for me! I can give up horizontal scrolling for this fix; I don't use it much anyway. Thanks! – Hendy Dec 22 '11 at 3:03
Though this had worked for me in the past, it does no longer. – rbellamy Sep 26 '14 at 14:37
@rbellamy, something must be different in your setup now. For me it still works. You can open another question if your situation is different from the one specified here and we'll try to troubleshoot it. – Czar Sep 28 '14 at 23:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .