Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The registry mods here for setting a Windows 7 AutoAdminLogon on a Domain worked beautifully, except:

The submission of username and password is before the domain server is available to authenticate logon, so I get this error:

There are currently no logon servers available to service the logon request

Once I click on the OK button and manually enter the password, the logon completes fine.

Is there a BIOS or network setting that would help solve this problem?

It is a Windows 7 notebook used in a kiosk. The wireless is turned off.

share|improve this question
    
What is the value of the "CachedLogonsCount" in "HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\Current Version\Winlogon\"? If the value is 0 there is no cached information and it will try to connect to de DC for credentials. –  n00b Aug 28 '11 at 10:48
    
Thanks for this tip... It helped. Our default policy is "0" and all worked when increased to "1" –  Robert Glantz Aug 31 '11 at 16:03
add comment

3 Answers 3

I was trying to get our computers to autologin as a domain admin user after imaging. To get this to work I did the following

  1. In the Local Group Policy Editor, go to "Computer Configuration" -> "Administrative Templates" -> "System" -> "Logon" -> "Always wait for the network at computer startup and logon" as @bloodphilia said

  2. In the Local Group Policy Editor go to "Computer Configuration" -> "Administrative Templates" -> "System" -> "Group Policy" -> set "Startup policy processing wait time" to 120.

For some reason the "Always wait for the network at computer startup and logon" doesn't always work, it seems like it was just a matter of timing. About 80% of the time I would get an error of "no domain controllers available". The added delay of the "Startup policy processing wait time" made it so the autologin always works.

share|improve this answer
add comment

If you're in a domain with policy groups the best solution is make a new domain policy group with the name "kiosks" and with the computers that don't work as well as you want.

Modify the values of "Computer Configuration" > "Administrative Templates" > "System" > "Logon" > "Always wait for the network at computer startup and logon" as @bloodphilia said.

If you read the help of the policy it says: "If you want to grant the aplication of Redirection folders, installation of software or the roaming profiles in an standalone login, turn it on this configuration to guarantee that Windows wait to the avaliability of the network before the policy will be available" (maybe my translation is wrong, assure to check in your own language)

So, it seems that your kiosk has a roaming profile or a mandatory profile with a folder redirection that don't let to start the system without network. There is a looooong thread about that in technet with different ways to work in (regedit, domain policy and local policy tweaks).

hope some of it works! :D

share|improve this answer
add comment

I'm not sure if this solves your question or if it even is what you are asking, but it seems like your computer is trying to logon to a domain server before the network is ready. If this is case, you might want to change the group policy.

Go to Start -> type in "gpedit.msc" in the run/search field.

In the Local Group Policy Editor that pops up, go to "Computer Configuration" -> "Administrative Templates" -> "System" -> "Logon" -> "Always wait for the network at computer startup and logon"

Double click the latter and set it to "enabled".

share|improve this answer
    
It could work if there is no "domain group policy" that will override the local policy when it'll logon. technet.microsoft.com/en-us/library/cc785665(WS.10).aspx –  n00b Aug 28 '11 at 11:12
    
This tip also helped... Between the cached logons and this tip, the AutoAdminLogon worked flawlessly... –  Robert Glantz Aug 31 '11 at 16:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.