Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried to clone the linux kernel but it fails with the following output:

...
remote: Counting objects: 2134058, done.
remote: Compressing objects: 100% (334223/334223), done.
Receiving objects: 100% (2134058/2134058), 416.87 MiB | 175 KiB/s, done.
remote: Total 2134058 (delta 1780715), reused 2133164 (delta 1779980)
Resolving deltas: 100% (1780715/1780715), done.
error: index-pack died of signal 13
fatal: index-pack failed
[...]@ubuntu:~$

What does this error mean? Can I somehow recover the files I downloaded? (I only have a slow internet connection available at the moment)

Nothing appears to be in the directory that I tried to clone the repository to.

Edit:

The command:

 git clone git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git

It looks like git did nothing in the directory no .git directory.

share|improve this question
    
Is the .git subdirectory also empty? – grawity Aug 27 '11 at 19:26
    
How about giving us the command you issued? – bahamat Aug 27 '11 at 20:04
up vote 0 down vote accepted

I am still not sure what caused the problem, I reinstalled git and now it works. Sorry, for this unsatisfying answer.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .