Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having trouble getting my Ubuntu 10.04 machine (Sony Vaio VGN-SR490) to connect to the Internet by way of an Ethernet cable connected directly to my router.

I'm able to connect to the Internet using this same cable using a Windows machine, so there's something wrong with the way Linux is configured.

How do I got about figuring out what the problem is and solving it?

Here are my network settings on Linux:

$ ifconfig

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1

vmnet1    Link encap:Ethernet  HWaddr 00:50:56:c0:00:01  
          inet addr:192.168.79.1  Bcast:192.168.79.255  Mask:255.255.255.0
          inet6 addr: fe80::250:56ff:fec0:1/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

vmnet8    Link encap:Ethernet  HWaddr 00:50:56:c0:00:08  
          inet addr:192.168.192.1  Bcast:192.168.192.255  Mask:255.255.255.0
          inet6 addr: fe80::250:56ff:fec0:8/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

Here are my network settings on Windows (Vista):

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . : [removed by me].
   Link-local IPv6 Address . . . . . : [removed by me]
   IPv4 Address. . . . . . . . . . . : 192.168.1.103
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.1.1

I censored my IP address from these results. If that information is needed, just let me know.

Here is the content of /etc/network/interfaces:

auto lo
iface lo inet loopback

After adding auto eth0, here are the latest results:

$ sudo ifup eth0

Internet Systems Consortium DHCP Client V3.1.3
Copyright 2004-2009 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

SIOCSIFADDR: No such device
eth0: ERROR while getting interface flags: No such device
eth0: ERROR while getting interface flags: No such device
Bind socket to interface: No such device
Failed to bring up eth0.

Here are the results of running a modprobe:

$ sudo modprobe msk

FATAL: Module msk not found.

$ dmesg | grep eth

I removed Linux from my computer and installed Windows XP, at the request of some of the people commenting on this question. I installed an ran a program to find out details about the network card. Here is that information:

Network
    You are not connected to the internet
        Computer Name
            NetBIOS Name    JOE-LAPTOP
            DNS Name    joe-laptop
            Domain Name joe-laptop
        Remote Desktop
                Console
                    State   Active
                    Domain  joe-laptop
                RDP-Tcp
                    State   Listen
        WinInet Info
            An internal error occurred.
        Wi-Fi Info
            Wi-Fi not enabled
        WinHTTPInfo
            WinHTTPSessionProxyType No proxy
            Session Proxy
            Session Proxy Bypass
            Connect Retries 5
            Connect Timeout 60000
            HTTP Version    HTTP 1.1
            Max Connects Per 1.0 Servers    INFINITE
            Max Connects Per Servers    INFINITE
            Max HTTP automatic redirects    10
            Max HTTP status continue    10
            Send Timeout    30000
            IEProxy Auto Detect No
            IEProxy Auto Config
            IEProxy
            IEProxy Bypass
            Default Proxy Config Access Type    No proxy
            Default Config Proxy
            Default Config Proxy Bypass
        Adapters List
        Network Shares
            No network shares

It looks like the network adapters list is empty. I will now install both Windows XP and Ubuntu Linux dual-boot. I'm still not able to access the internet, even through Windows. I'm wonder if this could be a hardware problem with the computer or a problem with the router itself. Other computers can connect to this same router, and work fine. (That's how I'm posting this after all!)

share|improve this question
    
Thanks for sticking with me. I tried to shorten your post a bit so we can see things clearer (You can also delete a few comments if you like). The error you're having seems to be very common with Ubuntu and VMware. Are you actually running Ubuntu itself as a virtual machine? Or is Ubuntu installed on the computer? Web search for SIOCSIFADDR: No such device brings up a bit, but it seems to be related to Ubuntu as a virtual machine. –  slhck Aug 27 '11 at 21:51
    
Would you post the results of dmesg | grep eth and also see whether any network interfaces are listed using lspci –  Linker3000 Aug 27 '11 at 21:52
    
@slhck No, Ubuntu is not running as a virtual machine. I have installed Ubuntu as the operating system on my computer. VMware is installed, but is not currently running. Interestingly, I just booted my computer from a Ubuntu LiveCD, and am experiencing the exact same problem, even after following your instructions on the LiveCD. I'm starting to strongly suspect it's a hardware problem. –  Kathryn Hallett Aug 27 '11 at 22:01
    
@Linker3000 The results of running dmesg | grep eth were empty, and I don't see any network interfaces listed using lspci –  Kathryn Hallett Aug 27 '11 at 22:07
    
Can you post mke/model of machine or if it's a DIY the motherboard make and model OR if you can boot Windows see what network interface is listed in device manager –  Linker3000 Aug 27 '11 at 22:10

4 Answers 4

I dont see anything in the comments suggesting that you look into udev and its rules which should install eth0. On my system, in /etc/udev/rules.d/75-network-devices.rules, I have the following;

# Local network rules to name your network cards.
#
# These rules were generated by nethelper.sh, but you can
# customize them.
#
# You may edit them as needed.
# (If, for example, your machine has more than one network
# card and you need to be sure they will always be given
# the same name, like eth0, based on the MAC address)
#
# If you delete this file, /lib/udev/nethelper.sh will try to
# generate it again the next time udev is started.

KERNEL=="eth?", ATTR{address}=="original has my MAC address here", NAME="eth0"

Also, make sure you have udevd running. This is what creates ethx on a Slackware based system.

share|improve this answer
    
I came across this post while looking for a similar solution, Can you just point out how can I find out the MAC address of my ethernet card even if I cannot see it listed anywhere ? –  Gufran Feb 6 '13 at 18:30
    
Thanks. This resolved my issue. On ubuntu 12.04 LTS I had /etc/udev/rules.d/70-persistent-net.rules which listed my two interfaces as eth2 and eth3, althought dmesg | grep eth listed them as eth0, eth1. That happened because system was previously on different hardware, thus different MAC addresses and different identifiers after all. This answer helped me find out the issue. Thanks. –  Janis Veinbergs Sep 27 '13 at 15:54

First of all, your ethernet isn't being managed by Ubuntu. Try ifconfig -a instead of just ifconfig, so you can see all your networking devices, managed or not. If you do see ethX in the ifconfig -a list, the solution should be straightforward, and you seemed to have gotten half of it. The following needs to go into your /etc/network/interfaces file:

auto ethX
iface ethX inet dhcp

The first line "activates" management of the interface and the second line sets it to DHCP and IP.

However, if you don't even see any ethX interfaces when you do ifconfig -a, it's a driver issue (Ubuntu isn't even seeing the interface). To solve this, either check from Windows' device manager for the PCI Vendor ID and Device ID of your ethernet card, which you can cross-reference here and see if you can find a driver for that (Vendor ID is the manufacturer, Device ID is the acutal model of the ethernet card). An alternative in-linux way to do this is via lspci.

In Windows 7, getting the Vendor/Device IDs is through the Device Manager -- open up the Network Interfaces node, double click on your network card, click on 'detail', and select "Hardware IDs" from the drop-down list. The Vendor ID are the 4 hexadecimal digits after the VEN_ prefix, and the device id is the 4 hex digits after the &DEV_ immediately following the vendor.

share|improve this answer

You may also want to try ls /etc/init.d | grep eth and see if there is anything in the init as an artifact that ETH0 was ever there. The above is what use in Gentoo, I think Ubuntu uses a different mechanism but its worth a shot.

Back in Ubuntu 6.06 I had an issue like this, I ended clearing the CMOS on the MB and somehow it solved my problem. That's a stab in the dark though.

share|improve this answer
SIOCSIFADDR: No such device
eth0: ERROR while getting interface flags: No such device
eth0: ERROR while getting interface flags: No such device
Bind socket to interface: No such device
Failed to bring up eth0.

You only need to rename the 70-persistent-net.rules file in /etc/udev/rules.d.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.