Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My ISP provides native IPv6 support (ie. I can plug in my computer straight into the WAN and get an IPv6 address). However I can not get this working on DD-WRT. When I enable IPv6 and radvd in DD-WRT, the router gets in IPv6 address, but the devices on my LAN do not.
I tried looking at the DD-WRT wiki, but this only displayed instructions for tunneling or other methods where native support isn't available. I found a small amount of sites thorough searching, but none of the methods these sites described gave my computers each a global IPv6 address. In addition, SSHing into the router using ping6 on sites such as ipv6.google.com causes "host unreachable" errors.

Has anyone using DD-WRT configured a successful setup with native IPv6?

I am using a Netgear WNDR3700 v2, with DD-WRT build 17201

share|improve this question
    
What router are you using? –  Simon Sheehan Aug 28 '11 at 1:05
    
I'm using a Netgear WNDR3700 v2, with DD-WRT build 17201. –  Matt Aug 28 '11 at 1:30
    
thanks, I added it to the question for you so it will be easier for others to help you :) –  Simon Sheehan Aug 28 '11 at 1:57
    
Does your ISP assign you a single address or a /64 subnet? –  grawity Aug 28 '11 at 12:43
add comment

2 Answers

“Native” IPv6 is provided by ISPs using a protocol called DHCPv6-PD (Prefix Delegation). This requires that your router sends a DHCPv6 request to the ISP to ask for a prefix, then uses the prefix that it received to give out addresses to the computers on your lan.

DD-WRT does not currently include the tools required for this to function, although you may be able to get it working by manually installing additional tools and running a startup script.

share|improve this answer
add comment

IPv6 only provides autoconfiguration for hosts, not for routers. So your router, as a host on your ISP's network, is getting an IPv6 address from your provider. But as the router for your network, it is not getting a subnet assigned that it can advertise for use on your LAN.

You need a /64 subnet assigned to you by your ISP. Once you configure that subnet for your LAN interface (and in radvd.conf) and enable radvd, autoconfiguration should work on your LAN.

You got the native support working correctly. Your router is now an IPv6 device. You just need to do the LAN portion, and that is independent of whether the router's connection is native or tunneled.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.