Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I use Virtualbox with Windows on Ubuntu host. I keep it on separate workspace (I use Xmonad). Xmonad uses Windows key as modifier. The problem is: when I press it, Windows machine opens start menu. Disabling keyboard autocapture helped a bit, but not completely. So, is there a way to setup Virtualbox in a way, so it will completely ignore specific keys or sequences?

share|improve this question
1  
One might be interested in the fact that the «AwesomWM» out of the box doesn't allow to intercept its keys to VirtualBox. I just moved to the XMonad because I am not interested in Lua, but wanted to learn Haskell, and found that this have no this featur ☹ – Hi-Angel Feb 10 '15 at 7:16

These work for the guest windows in non Virtualbox environments and should control the guest.
In the windows guest can you right click on the desktop and select:-
-> graphic options -> then Hotkeys -> disable.
Disable all Hotkeys except win+l win+u-, reboot required.
http://www.autohotkey.com/docs/misc/Override.htm
I've tested on win 7 [options -> disable, the other says it works on all OS's(it is a Registry hack, normal warnings on reg.)]
Hope one of them works.

share|improve this answer

Try adding this in your .xmonad/xmonad.hs file:

((0, xK_Super_L), return ())

Got it from here: http://comments.gmane.org/gmane.comp.lang.haskell.xmonad/12141

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .